Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account

Why is asset searching TERRIBLE!?

The search in Roll20 is the worst I think I've ever seen. My 10-year-old could write a better search algorithm than whatever is being used in Roll20 (exaggeration but you get what I mean). Why is that? Almost none of my purchased assets show up but it's eager to show assets I can purchase! It means that I need to know everything that is under everything I purchased. Because I can't search for any of it. I search for the word Log... I don't get any logs even though the name of one of my assets is "log."  I see posts from a year and more ago with no resolutions. Is this being worked on at all? 
1618900316
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
I just did a search on "log" and found dozens and dozens of results. Are you clicking "Marketplace items" before you enter the search term? And are you using the type selector? What browser are you using?
1618934303

Edited 1618934345
So, I've tried a few different ways and I don't get it. It doesn't make sense to me. It's in the name but it doesn't show up. This is an issue every time I try to build a map.  EDIT: Forgot to add that I"m using Chrome as a browser. It's supposed to be supported. 
1618938104
I too see this issue, for instance for control, I search for "Airship" which everyone should have tons of entries for in pro cause we just had a marketplace free handout of airship assets.  No matter what drop down you choose to search for it never returns any of the airship files other than the same one which I suspect has some sort of tag or file parse tag that has the word airship in it.  All the actual named airship objects do not come up, while the marketplace suggested purchases and the web return super fast results.  The search in our own folders/purchases seems to be either disabled or broken.  
1618961205
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
I do know that for some reason, premium sets (like character art packs you get with a module) don't show up under searches.
1618961802
My guess is that parsing the actual user accounts purchases is an intensive resource hog so they tried to go a tag route but most of the older content products have no tags setup or their tags are missing.  Searching the marketplace and online are faster probably because they offload the search to an external search engine.  
For what it is worth, this is how i try to manage searching purchased assets. - download the zip files of all downloadable ses - rename the numbered zip file to the name of the art-set  and  unzip the zip files - search locally - the folder name is the set you are looking for - navigate to the right set - scroll until the asset if found. This is the worst workflow ever, but i can't find a faster way.
Been having the same issue for as long as I can remember, just thought it was Roll20. I even try to search for assets bundled with newly released modules by wizards of the coast (Tasha's CoE) but nothing from my purchases show up. Only Google's assets and stuff I can purchase. 
1619136691
Gold
Forum Champion
I have seen the same problem (not today, but periodically when searching in-game). From times I researched/tested in the past, it seemed that the search hits the 3 "Tags" on your purchased Marketplace items, but fails to pick up the Asset Name (the title, the asset name). I think that's a bug that's been around for 6 months or more. I'd like to hear Roll20 Team comment and answer whether the Title is intentionally omitted or to-do testing and find the conditions where it's not.