Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
We're investigating unusual elevated traffic on voice and video servers that is affecting connectivity. We are working towards a solution as quickly as possible! Sorry for the trouble!
Create a free account

Dynamic Lighting - Updates, Bugs, & Feedback

1672361972
Gauss
Forum Champion
Richard B. I responded in your other thread. Short version is, stick to polygon/lines to avoid artifacts like this. Don't use circles or freehand. And when doing polygon/lines do not close it by meeting the head and tail together. Right click to end it instead. 
Hello! The door feature is AWESOME. I'm noticing (since today at least) that they are not being dropped with lines. Just a circle with a door that does not block dynamic lighting. When I first started dropping these a few days ago I could stretch a line left and right of the door to block the doorway.
1673222926
Brian C.
Pro
Marketplace Creator
Compendium Curator
TG said: Hello! The door feature is AWESOME. I'm noticing (since today at least) that they are not being dropped with lines. Just a circle with a door that does not block dynamic lighting. When I first started dropping these a few days ago I could stretch a line left and right of the door to block the doorway. Placement of doors/windows really only works well when you are on the DL layer. The lines show up there.
1673250709

Edited 1673250729
And the effects of it are only noticable when signed in as player OR using a dummy Account! CTRL+L does NOT show the exact view! (Fell for this the first time I was messing around with windows / doors) Brian C. said: TG said: Hello! The door feature is AWESOME. I'm noticing (since today at least) that they are not being dropped with lines. Just a circle with a door that does not block dynamic lighting. When I first started dropping these a few days ago I could stretch a line left and right of the door to block the doorway. Placement of doors/windows really only works well when you are on the DL layer. The lines show up there.
1673254448
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
TheMarkus1204 said: And the effects of it are only noticable when signed in as player OR using a dummy Account! CTRL+L does NOT show the exact view! (Fell for this the first time I was messing around with windows / doors) Where is Ctrl-L falling down? I know it shows the doors and windows in a more or less GM view, for example, it displays hidden doors. But that's not within the scope of Ctrl-L, which is intended to show Line of Sight. And of course, handles and spans only display on the DL layer. Again, I think this is proper behavior. I don't want my play view cluttered with lines and circles. I.e. what is the expected behavior vs. the observed behavior?
The effect is the players saw around the door without opening it. I had to delete it and add a replacement one on-the-fly.
I'm wondering now if I put the doors on the Map layer? Or I moved them to the Map layer? Going to keep an eye on this one.
1673841201

Edited 1673842806
Brian C.
Pro
Marketplace Creator
Compendium Curator
TG said: I'm wondering now if I put the doors on the Map layer? Or I moved them to the Map layer? Going to keep an eye on this one. Did you place the doors on the Dynamic Lighting layer? It sounds like the handles were not set in the correct locations.
1673841411
Brian C.
Pro
Marketplace Creator
Compendium Curator
The doors have not been added correctly to the Undo stack. Add 3 doors to the map. Hit Ctrl+Z 6 times. Instead of the first three uses of Ctrl-Z removing the 3 new doors, you get the following behavior: Third door is removed. Third door is added again. Second door is removed. Second door is added again. First door is removed. First door is added again.
I tried the doors with no luck. My question is this. It has been a while since I have run a game and set up a map. However, I imported a map, put in regular dynamic lighting and plugged in a token a set it all up with settings. Went into player mode to get a since of what it was going to look like. I got total blackness. The only thing i could do was control -l and that worked. What have I done wrong. I did import the map into an old game i had laying around. Any thoughts.
1673938896
Gauss
Forum Champion
Alan M. said: I tried the doors with no luck. My question is this. It has been a while since I have run a game and set up a map. However, I imported a map, put in regular dynamic lighting and plugged in a token a set it all up with settings. Went into player mode to get a since of what it was going to look like. I got total blackness. The only thing i could do was control -l and that worked. What have I done wrong. I did import the map into an old game i had laying around. Any thoughts. Ctrl+L does not check lighting, it checks line of sight, a different thing.  1) Verify that you have assigned the token to yourself.  2) Verify that the token has sight 3) Verify that the token has a light source (either it's own or another light source nearby) or night vision.  4) Verify that Fog of War/Permanent Darkness is not turned on, or if it is, is cleared in that area.  5) Move the token once, you may have "Update when Token Drop" turned on, which means you have to move the token.  6) Verify that the player ribbon is set to the correct page. You as GM could be on a different page than you as player.  Bonus) Create a second dummy account, run it in a second browser (or in incognito/privacy mode), that allows you to check controls immediately without the pain of switching back and forth between GM and player modes.
1673969901
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
More information on a  Dummy Account .
I've posted here before asking why Dymanic Lighting was laggy. In short, it becomes unbearably laggy when more than one token with sight is on the board. Legacy does not cause this issue... but the newer cool features like being able to open DOORS isn't backwards compatible, so I can't exactly ignore this issue anymore if I want to be using them. To answer a question from Gauss back when I first posted (I'm sorry; it won't let me quote it, so I'll just put it here:  Are you as the GM assigning control of the tokens to yourself?) For the players? No. I'm assigning them to the players. Why would I assign them to myself unless they're my NPC? Of which I do have one with vision, but it doesn't really matter if I give them vision since I can see the vision of all tokens with vision since I am the almighty DM, right? I need help here. It's to the point where a single light source is enough to start lagging me.
1674686770
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Elizabeth! To answer one question, assigning control to yourself as GM solves some transparency issues when using Explorer Mode. I have an info graphic I can post that explains this if you are curious. I see that your issue was not with Explorer Mode, but that is one reason the permissions are recommended to be granted that way. As for the lag issue, what steps have you taken to try to remedy it? Have you tried toggling Hardware Acceleration in your browser, for instance? It is difficult to give specific help without mored details. Here is a page with suggestions .
Hardware Acceleration is toggled on. I'm actually surprised it was already toggled on. I haven't exactly taken many steps except not use the new dynamic lighting because I don't know what steps I could take to help it not lag, or at least lag less.
1675133207
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Elizabeth C. said: Hardware Acceleration is toggled on. I'm actually surprised it was already toggled on. I haven't exactly taken many steps except not use the new dynamic lighting because I don't know what steps I could take to help it not lag, or at least lag less. Sorry, I should have been more specific. By toggle, I meant if it is on, try turning it off and vice versa. In 99% of cases, it should be on for best performance, yet a small number of folks report better behavior with it off. Then if that doesn't help, try toggling it back. Does lag appear and disappear for you when you are specifically using/not using Dynamic lighting? (I as, because there are other things that can cause lag)
Elizabeth C. said: Hardware Acceleration is toggled on. I'm actually surprised it was already toggled on. I haven't exactly taken many steps except not use the new dynamic lighting because I don't know what steps I could take to help it not lag, or at least lag less. Also see if Explorer Mode is on. I could not get rid of lag with it on on my previous PC (one of the reasons I upgraded) without turning it off, but that fixed my lag…
I've been trying to get Fog of War, Advanced Fog of War, and Dynamic Lighting to work properly for days.  I've tried following the instructions for everything, but it's a mess.  It's been nothing but hit-or-miss with the application.  Sometimes tokens create exploration paths, and sometimes they don't (and that's on one page).  I have set each page's settings to allow for Fog of War, Dynamic Lighting, Advanced Fog of War, and I've been adjusting token settings and experimenting relentlessly, and nothing stays consistent.  When I "CTRL+L" a player's token, I can't see their token, they have no aura of light (even though it's set to be a 5' diameter), and the stat bar digits for "hidden" tokens are visible.  I took players through a map in which their tokens actually "explored" and laid out a visible, cleared path behind them (what I actually wanted), but then going back to the same page later to see how I had it set up, it didn't work anymore, and the tokens don't affect the FoW.  Sometimes a player's token is visible to them in the fog, sometimes it isn't.  I think I've tried about 6,294,909,973 combinations of toggle arrangements between tokens and page settings, and I get nothing useful except a huge circle of exposed map that the players can see (so, the entire dungeon), or darkness and tokens with zero light auras on a black map that I have to reveal. I'm beyond confused and I wish there would be a final decision on what thing is being called what.  Could "Dynamic Lighting" or "Super Dynamic Lighting" or whatever it's supposed to be just finally take the place of "Advanced Fog of War" or "Advanced Super Ultimate Legacy Lighting" for Pete's sake??   So I guess my questions are: -How do I set up FoW so that tokens can explore and clear the fog as they go while leaving the map also cleared behind them? -How can tokens have auras established that don't vanish? -How can I set the distance from their tokens to be a certain number of squares/feet so that it remains appropriate for those with night vision and those who do not have it? -How can I make sure the map is actually blacked out for the players unless their tokens reveal their proximity? I know all of this is in the tutorials, but it's not working for me, so I'm wondering if it's an external setting or function I'm missing.  I'm using chrome, and the FoW works the way I want intermittently, but I just can't seem to get it to stay consistent and reproducible between pages even when I use the same settings for each page.
1675555650
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
All I can offer is the checklist for now. But I am currently working on a DL Tool script, which should include "Why can't my token see?" diagnostics.
1675814691
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
keithcurtis said: All I can offer is the checklist for now. But I am currently working on a DL Tool script, which should include "Why can't my token see?" diagnostics. The script is called DLTools , and is posted. You can find details here , but here is an example of the diagnostic tool part of it:
One bug I've encountered with the new door/window tool that I definitely think should be fixed is as follows. If I place a door or window on the dynamic lighting layer, then interact with it in the token layer (for instance) to open it, it should not be possible to accidentally drag the door around from that layer. It should only be able to be dragged around if I am on the dynamic lighting layer where I placed the door or window. Thanks for a prompt fix!
1675965035

Edited 1675965414
Edit: Saw Mark's post from November. Guess Explorer Mode is still busted? :( Not seeing the answer to this, so probably something on my end, but not sure. When using dynamic lighting in the Dungeon of the Mad Mage module (5e), my players seem to get full vision of the map somewhat randomly (but also frequently). This was very common on the map "Level 3: Sargauth Level". The weird part is that if I used CMD+L to see what my players' vision looked like, it showed as expected.  We've also seen this impact one player, but not the others, at different times. I'm running Chrome  Version 110.0.5481.77 (Official Build) (arm64) -> latest , and my friends are primarily using Chrome with one person on Edge (though he tried Chrome last night to see if that helped). Dynamic lighting did seem to work as expected on Level 1 and in the Tales from the Yawning Portal Sunless Citadel adventure, FWIW. Thanks!
1675967187
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Paul Ruiz said: Edit: Saw Mark's post from November. Guess Explorer Mode is still busted? :( Can you link that post? I couldn't find a post by a user named "Mark" in November for this thread. Explorer Mode largely works for our group. I have run Sunless Citadel without major issue, too. I can certainly see the possibility of problems with DotMM, though. It has a lot of huge maps (TT designers don't really consider the needs of VTTs), that really push the edges of what works.
1675974473

Edited 1675976046
keithcurtis said: Paul Ruiz said: Edit: Saw Mark's post from November. Guess Explorer Mode is still busted? :( Can you link that post? I couldn't find a post by a user named "Mark" in November for this thread. Explorer Mode largely works for our group. I have run Sunless Citadel without major issue, too. I can certainly see the possibility of problems with DotMM, though. It has a lot of huge maps (TT designers don't really consider the needs of VTTs), that really push the edges of what works. Whoops, sorry, not `mark`, `mike` :)&nbsp; <a href="https://app.roll20.net/forum/post/10223955/dynamic-lighting-updates-bugs-and-feedback/?pageforid=11180566#post-11180566" rel="nofollow">https://app.roll20.net/forum/post/10223955/dynamic-lighting-updates-bugs-and-feedback/?pageforid=11180566#post-11180566</a> Looks like page 13 has some other DoMM dynamic lighting issues, too:&nbsp;<a href="https://app.roll20.net/forum/post/10223955/dynamic-lighting-updates-bugs-and-feedback/?pageforid=11102662#post-11102662" rel="nofollow">https://app.roll20.net/forum/post/10223955/dynamic-lighting-updates-bugs-and-feedback/?pageforid=11102662#post-11102662</a>
1675976428
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Thanks! Yeah I remember that report. I have experienced that issue too, but not in at least a year. I've more often encountered smaller bugs, like a light suddenly giving off darkness instead of illumination, or a loss of all light, but not a total reveal. Most problems of this nature can be solved by reloading the game, but if you have a player that for whatever reason is prone to it, I can understand the frustration. It would be nice if the VTT could detect a local failure and present an alternative (such as blanking the screen with a reload message).
1675976773

Edited 1675987469
So unfortunately refreshing doesn't fix it, either. If it helps, you're also more than welcome to join our Wednesday night (Mountain time - Denver US) games to see if you can catch any error logs (or whenever if it's possible to replicate with one person, but replicating based on the real scenario is always helpful :)). Right now I've just been resetting explored darkness and trying to move a token back along their path (though I stopped that since it kept happening), or setting up the old style fog of war with revealing a block at a time.
keithcurtis said: keithcurtis said: All I can offer is the checklist for now. But I am currently working on a DL Tool script, which should include "Why can't my token see?" diagnostics. The script is called DLTools , and is posted. You can find details here , but here is an example of the diagnostic tool part of it: Keith! You're amazing!
I wanted to report a bug: I edited one of my games last week, and it was the first time I used the doors feature. I don't know exactly what might have changed or disfigured it - or if one thing is related to the other - but today, when I tried to edit one of my games, simply all the maps are completely black, and you can't see anything at all. This is repeated in all maps of all games. Can anyone tell me what might have changed and what I can do about it?
1676062631
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
This is true of the GM view? No tokens or drawing lines, either?
<a href="https://www.youtube.com/watch?v=7IftmAljlk0" rel="nofollow">https://www.youtube.com/watch?v=7IftmAljlk0</a> Roll20 should update their videos. This one is useless @ the 1:34 time on the video. My tokens don't have a "sharpen Effect" on my roll20 game. Those of you that may have been here thru the changes that's nice and you have a reference point and know the changes. The new players have no clue and this is another bad video that Roll20 needs to update for their "paying" customers.
As far as Dynamic Lighting. I have fiddled with this setup for sometime now. I am happy with it but my players won't be able to see each other very well when they all get on and start moving about. I have my dummy account to confirm this. I cant do 120 degrees of light because the players won't be able to see each other. I will give them 210 degrees so the can sort of see beside themselves. I'm out of ideas unless I use BUMP script and have a leader and then attach a lantern to them in the gm layer that follows them around.
1678039863

Edited 1678040963
I'm not quite sure what you're trying to say here, The Keeper. Are you having your players emit light in a 210 degree cone or are you giving them 210 degrees of vision? If the map doesn't have Daylight Mode &nbsp;enabled and I want the players to provide their own light, I either give them a torch or lantern token that they can control, or I edit their token to have it emit light in the appropriate radius. (Since you have a Pro account, you can use the TokenMod MOD and a few custom macros to automate that). Although the token is emitting light 360 degrees, the player still can only see within 210 degree cone. This also allows other players to see by the light emitted by the token emitting that light. I've found that simulating lanterns and torches by having the player tokens emit light to be the simplest method because it involves fewer tokens on the map. I don't use separate tokens unless a player wants to throw or drop a torch/lantern and leave it behind. I do agree that that particular video is a little out of date - the mention of a "sharpen" effect had me going the first time I saw it mentioned as well. There are other videos about using token vision and dynamic lighting by others that are more up to date.&nbsp; The Keeper said: As far as Dynamic Lighting. I have fiddled with this setup for sometime now. I am happy with it but my players won't be able to see each other very well when they all get on and start moving about. I have my dummy account to confirm this. I cant do 120 degrees of light because the players won't be able to see each other. I will give them 210 degrees so the can sort of see beside themselves. I'm out of ideas unless I use BUMP script and have a leader and then attach a lantern to them in the gm layer that follows them around.
1678042619
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
If you are trying to simulate creeping around in the dark with only flashlights, I would turn on Daylight Mode, but set the brightness to like 10 or 15%. This will give them dim awareness of their surroundings, but provide bright light within the beams of their flashlights. If you need to hide things at the edge of perception, the bump script can handle that. Otherwise, your bump-lamp sounds like a decent solution if it is working for you. I'm not understanding how you have it set up, since tokens on the GM layer do not provide user-accessible light. Personally, if directional light is causing issues, drop it. It might be technically "realistic", but in real reality, people swing their beams around constantly, something the VTT does not simulate (and shouldn't because it would be very distracting). I'd just give them light with a radius and get on with playing the game. My two cents.
1678878443
Daniel S.
Pro
Marketplace Creator
Sheet Author
Command + Z or Control + Z doesn't seem to be working on the dynamic lighting layer. Happens for walls or oneway lighting the same. After I place a wall, the undo doesn't work. I'm using chrome and am not using any browser extensions. Happens in multiple campaigns, not just isolated to one campaign or map. Also, if I copy paste a token onto the map, and then press Command+Z, it undoes the last thing I deleted, but not the most recent action.
I'm having an issue with the doors. When I started using them a few months ago, they were always snaping to the grid, which was useful most of the time, but slightly annoying when I was using maps where the door placement wasn't perfectly aligned with the grid. Then, without me doing anything, they stopped snaping automatically, which was great for me. But now they're snaping again. I didn't change anything, I don't know if there is a way to choose whether they should snap or not but this is really annoying.
Daniel S. said: Command + Z or Control + Z doesn't seem to be working on the dynamic lighting layer. Happens for walls or oneway lighting the same. After I place a wall, the undo doesn't work. I'm using chrome and am not using any browser extensions. Happens in multiple campaigns, not just isolated to one campaign or map. Hey Daniel, I'm unable to reproduce what you're seeing here. Maybe I've got the steps to reproduce wrong. Can you give me what steps you go through to reproduce this issue? Also, if I copy paste a token onto the map, and then press Command+Z, it undoes the last thing I deleted, but not the most recent action. However, I am able to reproduce this issue. I've created a bug for it on our team backlog although I can give no guarantee when we'll be able to get to it, I will update you when we have it fixed.
Hi. My dynamic lighting layers have disappeared from all of my maps. I last logged in about two weeks ago. I needed to prep for this weekend and now I have no lighting options. I certainly did not turn it off, but even if I had, there is no option to turn it back on in the map page settings. Help!
1679061550
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Drew! Are you the creator of the game, and you are logged in as GM? Can you get to the settings page?
Hi keithcurtis. I am not the creator, but I am the GM. I'm not sure about the settings. Seems like there are settings on many different pages.
1679065496
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Drew W. said: Hi keithcurtis. I am not the creator, but I am the GM. I'm not sure about the settings. Seems like there are settings on many different pages. That was my guess, based on what you were saying. Check if the creator of the game still has a plus or pro account. The creator determines the features available. That's also the reason I asked about the settings page, accessible from the game home page (the page you see before you launch the game). The settings page is only available to the creator of the game. My guess is that the creator has let their subscription lapse.
Hello there ! I have a problem with Dynamic Light. So, My walls are set, my tokens have vision (and even night vision), and when I hit ctrl+L I can see what the token is supposed to see but when I switch from GM editing mode to player mode, The whole page is completely black. I have tried to put a light on the map but doesn't change anything it's just pure black from the players' view. Can somebody help me ? I don't understand what I'm doing wrong. Thanks to those who will take some time to respond ! You're the best!
1679236681
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Mathieu! My first guess would be that the tokens are not assigned to be under the control of the account you are signing in under. Other than that, screen shots would help. Here's a "why can't my players see anything?" checklist. The important thing is to verify . Don't assume. This list is written with GMs in mind, but can help players work through issues with their GM. The token is on the VTT It is assigned to the character The player has control over the character The token is on the Token/Object layer It is not blocked off by DL lines from seeing the immediate surroundings Make sure the player is looking at their token's immediate area. Shift-Click and hold on the token to pull the player's view to that area. If Fog of War is being used, that the area the token is in has been cleared The player has not been Split from the Party (Check the Help Center if this is unfamiliar) If Dynamic Lighting of any kind is being used: The token has sight turned on The token has a light source, or Nightvision (UDL) or personal light (LDL) In UDL it may be necessary to move the token one square to get everything working, or in extreme cases, refresh the (user's) page. Can you see a rotating cube in this URL ? If not, the browser needs to be WebGL compatible (99%+ are).
I ran into a weird issue with my session this Sunday on 3/20/2023. For two of my players Dynamic Lighting was working fine but for the other two it was working intermittently. For the two players with the issue they would have functioning vision until they clicked and moved their token. After dropping their token in the new position the whole map would go black for them as if there were no light sources at all. They would then refresh the page and the vision would return and work as normal for them until they moved their token again. Moving the token with the arrows keys would sometimes work and cause the token to retain vision but sometimes that method would also fail. Both players tried using Firefox, Chrome, and OperaGX to test if it was the browser but none of them worked properly. Is this some kind of weird unique bug we ran into?
keithcurtis said: Hi Mathieu! My first guess would be that the tokens are not assigned to be under the control of the account you are signing in under. Other than that, screen shots would help. Here's a "why can't my players see anything?" checklist. The important thing is to verify . Don't assume. This list is written with GMs in mind, but can help players work through issues with their GM. The token is on the VTT It is assigned to the character The player has control over the character The token is on the Token/Object layer It is not blocked off by DL lines from seeing the immediate surroundings Make sure the player is looking at their token's immediate area. Shift-Click and hold on the token to pull the player's view to that area. If Fog of War is being used, that the area the token is in has been cleared The player has not been Split from the Party (Check the Help Center if this is unfamiliar) If Dynamic Lighting of any kind is being used: The token has sight turned on The token has a light source, or Nightvision (UDL) or personal light (LDL) In UDL it may be necessary to move the token one square to get everything working, or in extreme cases, refresh the (user's) page. Can you see a rotating cube in this URL ? If not, the browser needs to be WebGL compatible (99%+ are). Hello ! Thanks to you I found what was happening, Players had simply no control on their tokken. Thanks a lot
So I'm having a weird issue, see image; <a href="https://i.imgur.com/JRnwu3y.png" rel="nofollow">https://i.imgur.com/JRnwu3y.png</a> Context here, I'm using Legacy mode due to a player's somewhat bad PC and not having time to learn the new system(s) yet.&nbsp; For some reason, no matter what I do every time I start a new polygon/line it creates this diagonal divide.&nbsp; Note that there isn't any green going anywhere near the top left and for some reason it just wants to anchor to the top left corner of my map.&nbsp; No problem if I didn't have an interior and exterior wall that do not connect to one another...&nbsp; In fact this map I need to make 4 interior sections as the hallway runs around a central location and connects to the central location on the NSEW sides.&nbsp; I've never seen this before and don't know how long this has been a problem as I haven't had a need to use dynamic lighting recently (like...&nbsp; at least 4 or 5 months since the last time?) what am I doing wrong?&nbsp; Whats causing this?&nbsp; Trying to solve this issue before my session on Wednesday night...&nbsp; Wasn't expecting to have an issue and maps usually take me no time.&nbsp; I've tried spamming select tool in the space between and deleting on the DL layer, nothing.&nbsp; Even looking at the corner I don't see anything there that should be doing this.
1679460591

Edited 1679460677
Gauss
Forum Champion
Zen300 said: So I'm having a weird issue, see image; <a href="https://i.imgur.com/JRnwu3y.png" rel="nofollow">https://i.imgur.com/JRnwu3y.png</a> Context here, I'm using Legacy mode due to a player's somewhat bad PC and not having time to learn the new system(s) yet.&nbsp; For some reason, no matter what I do every time I start a new polygon/line it creates this diagonal divide.&nbsp; Note that there isn't any green going anywhere near the top left and for some reason it just wants to anchor to the top left corner of my map.&nbsp; No problem if I didn't have an interior and exterior wall that do not connect to one another...&nbsp; In fact this map I need to make 4 interior sections as the hallway runs around a central location and connects to the central location on the NSEW sides.&nbsp; I've never seen this before and don't know how long this has been a problem as I haven't had a need to use dynamic lighting recently (like...&nbsp; at least 4 or 5 months since the last time?) what am I doing wrong?&nbsp; Whats causing this?&nbsp; Trying to solve this issue before my session on Wednesday night...&nbsp; Wasn't expecting to have an issue and maps usually take me no time.&nbsp; I've tried spamming select tool in the space between and deleting on the DL layer, nothing.&nbsp; Even looking at the corner I don't see anything there that should be doing this. If I am not mistaken, Legacy Dynamic Lighting is no longer supported and so it may have bugs that are not going to be fixed as the Devs move away from it.&nbsp; I suggest trying this on a different, clean page, to see if the behavior replicates. If it does there may be nothing you can do about it other than migrate to the Updated Dynamic Lighting.&nbsp;
1679485010

Edited 1679485055
David M.
Pro
API Scripter
Zen300 said: So I'm having a weird issue, see image; <a href="https://i.imgur.com/JRnwu3y.png" rel="nofollow">https://i.imgur.com/JRnwu3y.png</a> Context here, I'm using Legacy mode... Weird diagonal blocking line + LDL sounds like you have at least one "closed" polygon on your map. There was a change in behavior quite a while ago for Legacy Lighting where if the polygon tool is used and the polygon is "closed" by attaching the last point to the first point, then this strange phantom diagonal line appears. The solution is to never fully close your polygons (overlapping lines are fine but not end_pt=begin_pt).&nbsp; If you have a particularly complicated closed polygon you don't want to redraw, you might want to check out the PathEditor script. It has functions that open/closes polygons automatically, among other things.
1682269885

Edited 1682270174
Noticed a heavy increase in lag sometime in the last three weeks.&nbsp; Very simple map, 50x25, only had 6 small lines of DL (switched to 3 one-way circles, no change in lag).&nbsp; Several NPCs without sight, 8ish PCs/etc with sight.&nbsp; Dragging one PC token a few squares takes a couple seconds, and a couple/few more for the lighting to update (CPU usage spikes to 88%).&nbsp; Map is only 600kb.&nbsp; Running in Chrome on Ubuntu, hardware acceleration togged on and off, and Explorer Mode on and off.&nbsp; Tried in Firefox (hadn't used for several years as Chrome worked better back then): sped up but have odd artifacts after moving tokens - usable at least but not great visually. 90% sure all of this will only affect me (the GM), but wanted to report as this is heavily worse than just 3 weeks ago. Edit: Also checked everything in the Graphics Troubleshooting page:&nbsp;<a href="https://help.roll20.net/hc/en-us/articles/4561713767703-Graphics-Performance-Troubleshooting#check-your-system-0-0" rel="nofollow">https://help.roll20.net/hc/en-us/articles/4561713767703-Graphics-Performance-Troubleshooting#check-your-system-0-0</a>
I have been using the new lighting system and i have noticed an Extreme case of lag where the maps become unplayable. So bad that it would cause my computer to freeze. This started around a few weeks ago at first i thought it was a cache so i cleaned it and got no fix i thought it was google specifically moved to fire fox and it helped not freeze my PC but the lag was still terrible. If my map had no tokens that relied on sight and non that used the map lighting i had no issues but then i placed a few tokens that had only vision turned on and the game starts to lag. (i have 6-7 players so this is an issue) then i made a map the second i turned on lighting it slowed tremendously. i only turned it on no tokens no walls just turned it on and it lagged. I decided to run a test to see if the old legacy lighting system would work better and it did. no lag what so ever. thought the solution would be just to swap to old reliable however the vision of the tokens are strangle locked n this weird diagonal line. im trying to block of line of sight and use global lighting but this diagonal line is an issue. the line appears from both sides of the token on legacy lighting so i don't think its a vision cone issue. i really am hoping for this new lighting system to work and to use it but at this point its been more of a downgrade than the old system. whats the point of using it if it lags to hell