Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account

Ammo tracking issue (probably human error)

1634003213
Hello! I created a tab for a paladin to use Turn the tide and was trying to get it to use as a resource/ammunition. I have a pro account and the API 5th edition OGL companion installed. I have ammo tracking turned on in the API and in the character sheet. Other ammo works for his other attacks.   What could I be doing wrong?
1634066137
under the equipment listing you need to check has an attack. Leave the actual attack left unchecked and it will work as you want
1634072309
I just tried that. Unfortunately it's still not working. 
1634119459
I was wrong in my first post. I entered everything the way your screen shots show and it works for me. 
1634156071
I don't understand why its not working then. :(
I had some stuff in the description field that lately was crashing the API. After cleaning up the description field my ammo tracker now works again.
1634169122
I've gone back over all of it. I emptied the description field and still doesn't work. I'm perplexed. Other items on the same characters sheet subtract ammo just fine. I've done similar on another character sheet to subtract charges on a magical item. Description and all works just fine. 
1634232914
The only other thing I can think of is that you have an added space at the end of the name "Channel Divinity" in the item name that is not included in the name typed into the ammo field of the attack. Or vice versa. 
Could there be a blank space at the end of the character's name?  That can also cause it to not work properly. -Adam
1634275117

Edited 1634275160
Oosh
Sheet Author
Are you able to post what the character sheet puts out when you click the attack? Either with the up arrow in the chat bar, then copy and paste or (even better) if you have a script logging chat messages to the API console then grab that instead, as it shows exactly what the API sees. The chat bar version is fine, if not. The Companion script is pretty old, and the way it grabs the ammo name is not ideal. It's possible that some template combinations will confused the hell out of it. A couple of things to try - does it work if you check the "attack" checkbox? Also, if you grab the string the sheet is sending to chat (up arrow in the chat bar after rolling it), then insert the following string after the &{template:dmg} bit, and before the rest of the macro: ammo=Channel Divinity {{charname=}} Then paste the whole lot back into chat. Does it fire now?
1634297612
So here's what i've got. I know I must be missing something. Just can't figure out what. I marked has an attack. There doesn't seem to be any spaces before or after the characters name or the name of Channel Divinity.  @{Andryd Silverblood|wtype}&{template:atkdmg} {{mod=-}} {{rname=Turn the Tide}} {{r1=[[0d20cs>20]]}} {{r2=[[0d20cs>20]]}} 0 {{range=}} {{damage=1}} {{dmg1flag=1}} {{dmg1=[[1d6 + 4[CHA]]]}} {{dmg1type=Healing}} 0 {{dmg2=[[0]]}} {{dmg2type=}} {{crit1=[[1d6[CRIT]]]}} {{crit2=[[0[CRIT]]]}} 0 {{desc=}}   {{spelllevel=}} {{innate=}} {{globalattack=@{Andryd Silverblood|global_attack_mod}}} {{globaldamage=[[0]]}} {{globaldamagecrit=[[0]]}} {{globaldamagetype=@{Andryd Silverblood|global_damage_mod_type}}} ammo=Channel Divinity@{Andryd Silverblood|charname_output}
1634333596
Solved! Finally did something I should have thought to try earlier. I deleted the 5e OGL companion script and re-loaded it. Now it works fine.