Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account

Avatar and "Speaking As"

1642104885
Alain H.
Pro
Sheet Author
API Scripter
Hello, I have a bug on a game with friends, when we change the "speaking as" it should change our portraits to match the characters, but it does not and impossible to find where it comes from, anyone have an idea? And it only does it on one game strangely.
1642106866
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Make sure that the character sheet has an Avatar image (not just a token image), and that you do not have video turned on.
1642108032
Alain H.
Pro
Sheet Author
API Scripter
The audio / video is not activated. And this is an avatar image.
1642114985

Edited 1642114997
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
This is something I just recently discovered—If the user name in the settings tab is the same as the character sheet tab, you may see two instances in the "speaking as" list. One for the player name and one for the character name. Player name is the one at the top ("I'm speaking as the player"). Try looking further down the list for the character name ("I'm speaking as the character"). As an aside, when troubleshooting, it's usually a good idea to try disabling any third party extensions that alter the Roll20 interface.
1642117008
Alain H.
Pro
Sheet Author
API Scripter
I've tried everything and nothing helps, but I think I know what it is. In fact, this is a game where my wife is a GM, and at one time she had removed the ability to display her avatar in "speaking as", when the option was still available. Except that the option is gone, but the setting is still there, so I don't know what to do.
1642121040
Kraynic
Pro
Sheet Author
In the Text Chat portion of the in-game Settings, do you have the option "Enable Chat Avatars" checked?
1642121066
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Did you check this area?
The New Interface is - sry to say - not good. Here is why: The Option you pointed out keith is hard to find as there is no cue you can find that option there and can click on that to see more options (was searching for the option to resize avatars). The Buttons for "Exit Game" or "Re-Join as Player / GM" are placed at the bottom of settings Menu. WHY is this the case? Why aren't those placed at the top? (Annoying especially if you want to Test something for your players and have to switch a lot to be sure everything works fine)...
1642174307
Alain H.
Pro
Sheet Author
API Scripter
keithcurtis said: Did you check this area? I don't have this checkbox. Kraynic said: In the Text Chat portion of the in-game Settings, do you have the option "Enable Chat Avatars" checked? Yes.
Alain H. said: keithcurtis said: Did you check this area? I don't have this checkbox. Kraynic said: In the Text Chat portion of the in-game Settings, do you have the option "Enable Chat Avatars" checked? Yes. Maybe it is disabled in Game settings outside of your game?
1642203622
Gold
Forum Champion
Are you the GM Creator of this game, Alain? That particular Checkbox that keith pointed to, may be available only to the GM-Creator of the game? Ask that person to check if it is disabled.
1642335072
Alain H.
Pro
Sheet Author
API Scripter
TheMarkus1204 said: Alain H. said: keithcurtis said: Did you check this area? I don't have this checkbox. Kraynic said: In the Text Chat portion of the in-game Settings, do you have the option "Enable Chat Avatars" checked? Yes. Maybe it is disabled in Game settings outside of your game? I couldn't find any options for this outside the game. Gold said: Are you the GM Creator of this game, Alain? That particular Checkbox that keith pointed to, may be available only to the GM-Creator of the game? Ask that person to check if it is disabled. I use the account of the creator of the game, who is my wife, and this option is not visible.
1642352110
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Alain, Found the solution. Turn on A/V chat. The option should appear. Check it. If you no longer wish A/V turn it off. The option should remain as set. This appears to be a bug in the new settings tab and should be reported.
1642467730
Gold
Forum Champion
keithcurtis said: Hi Alain, Found the solution. Turn on A/V chat. The option should appear. Check it. If you no longer wish A/V turn it off. The option should remain as set. This appears to be a bug in the new settings tab and should be reported. wow I hope that it is reported and fixed. What a confusing GUI flowchart mistake.
1642507333
Alain H.
Pro
Sheet Author
API Scripter
Thank you all, the problem is solved! Roll20 has already said they will look into it.