Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

Set Ability API Help

1649433458
Im using an api "Set abillity"&nbsp; <a href="https://app.roll20.net/forum/post/5362387/script-setability-a-hack-of-chatsetattr-to-set-abilities-via-chat-commands/?pageforid=5362387#post-5362387" rel="nofollow">https://app.roll20.net/forum/post/5362387/script-setability-a-hack-of-chatsetattr-to-set-abilities-via-chat-commands/?pageforid=5362387#post-5362387</a> &nbsp;and when tyring to use what i assume is the proper syntax, the replacement for % which is \p doesnt appear to work, does anyone know how to make it work as i cant seem to figure out the documentation. Here is my code !setability --sel --token --Usurper-Blade#\p{Saul|Usurper's-Blade} and here is the output: Setting abilities Setting abilities Usurper-Blade to \p{Saul|Usurper's-Blade} for character Saul.
1649459475

Edited 1649459488
Oosh
Sheet Author
I'm pretty sure that needs the --replace flag to work. I think Jakob messed up by leaving it off the example in that thread. You could also try a normal escape:&nbsp; &amp;percnt;
1649504673
%{Saul|Usurper's-Blade} is all that is sent, as it doesnt call the macro, how do i use the replace flag?