Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

Simple roll 20 macro cutting off for no discernable reason

1652452576

Edited 1652452809
Ok, I've been out of this a bit but have no idea why this macro won't work. &{template:default} {{name= Hacky hacky slashy slashy}} {{Attack 1 hits AC= [[1d20+5]]}} {{Damage= [[1d8+3]]}} {{Attack 2 Hits AC [[1d20+0]] }} {{Damage= [[1d8+3]]}} I've re made the macro 3 times from scratch in case there was something weird. It cuts off after the second attack and won't include the second damage line.  Everything is n the same line
1652452918
Kraynic
Pro
Sheet Author
You need to change the second damage label to Damage 2 (or whatever).  You need the property labels to all be unique within a macro or the roll template will ignore it.
Thank you....
1652459850
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
If you use an initial space: " Damage", you shouldn't be able to see the difference in the display.
1652647819
BigNorseWolf said: Ok, I've been out of this a bit but have no idea why this macro won't work. &{template:default} {{name= Hacky hacky slashy slashy}} {{Attack 1 hits AC= [[1d20+5]]}} {{Damage= [[1d8+3]]}} {{Attack 2 Hits AC [[1d20+0]] }} {{Damage= [[1d8+3]]}} I've re made the macro 3 times from scratch in case there was something weird. It cuts off after the second attack and won't include the second damage line.  Everything is n the same line You missed an = sign after "Attack 2 Hits AC"