Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

Token bar lag

1661630507
Ive noticed since the recent change to the token bars that large maps with lots of tokens on are now unplayable due to lag.  I have a Barrowmaze campaign, which has a large map with lots of tokens on.  Because the map is large the tokens are pretty small on it.  It now looks terrible because of the increase in size of the token bars (and they wont top overlap properly anymore) and i can barely scroll on the map due to lag.  We played on this map with no issue before recent changes.
1661634905
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hmm. I'd try some other solutions. I have a map with over 200 tokens on it, last half of which display token bars, and am experiencing no lag. I had some this morning, but a computer restart fixed that, so it might have been a cached data issue. Admittedly, my map is not using Dynamic Lighting, so that's another consideration. I'd suggest if not a restart, at least deleting cache and cookies and see if that helps. Another thing to test to see if this is directly token bar related is to turn on the new reveal on hover option in the settings sidebar (under Graphics) and see if that makes a difference. The display issues are certainly a concern though, and have been reported in several other threads. Token bars have not actually changed the amount of VTT they cover (though they are individually thicker, they are more tightly spaced), but they do cover more of the token on some settings.
1661637481
Ive restarted computer, cleared cache etc.  Still the same, severe lag on one game map.  If i turn on/off hover function it makes no difference.  So maybe it is not connected.  However, this did work fine a few weeks ago.
1661641660
Gauss
Forum Champion
Tariff said: Ive restarted computer, cleared cache etc.  Still the same, severe lag on one game map.  If i turn on/off hover function it makes no difference.  So maybe it is not connected.  However, this did work fine a few weeks ago. Tariff, which browser is this on? Have you tried any other browser? (Just making sure this is not a browser level issue.)
1661643213
I use Edge and Chrome.  I cleared cache/cookies on both and both are the same.  Severe lag on the barrowmaze map, just unplayable.  Frustrating as this used to work.  I think maybe i need to find another VTT.
1661645860
Gauss
Forum Champion
Tariff said: I use Edge and Chrome.  I cleared cache/cookies on both and both are the same.  Severe lag on the barrowmaze map, just unplayable.  Frustrating as this used to work.  I think maybe i need to find another VTT. Edge and Chrome are, under the hood, basically the same. Could you check Firefox?  Also, could you send me an invite? Maybe I can see what is going on on the map that might cause it. 
1661654317
I can. If you are zoomed out the map scrolls fine.  Its when you zoom in it all lags.  Im sure its the size of the map and number of tokens i have on it... but..it did work fine before.
I'm having the same problems, and so are all of my friends. If there are more than, like, a SMALL amount of assets on the map, it lags out beyond use. It's consistent between different people's computers, maps, and games. This update has honestly broken so much, all for the sake of some visual changes. We're hoping for an update to roll out to fix the various bugs that have cropped up, but until than, nothing else really can be done. ¯\_(ツ)_/¯
1661662101
Gauss
Forum Champion
James, could you send me a link to your game also? I'd like to come take a look and see if I can spot anything. 
1661722854
So, ive noticed something else.  I was just populating a NEW map with monsters.  Once i hit aboyt 20 monsters, ive noticed if you zoom in or out the map kind of judders, as if a rendering problem.  Again, it was only after i had populated a few monsters..the map is very small. This would explain the extreme lag im getting on my barrowmaze map. Others must be experiencing this.  It looks to me like its the new token bars causing it.
1661764193

Edited 1661764238
I have been having this problem with chrome for months now and tried everything they suggested. Quite honestly i don't think they even know what the problem is. The Dev Server works great, but u cant link Beyond20 to it. I suggest you try the Firefox Quantum (it fixed most of the issues) just change your shortcuts because they cross with Firefox. 
1661774225
I'll be changing VTT if it becomes too difficult to play on Roll20
1661796727
Gauss
Forum Champion
Tariff said: I'll be changing VTT if it becomes too difficult to play on Roll20 Please check your inbox. 
1661818509
Gauss
Forum Champion
Not sure if this is the same issue or not, but a Roll20 staff member has stated that they are aware of a performance issue that they are working on resolving.&nbsp; <a href="https://app.roll20.net/forum/post/11061146/not-sure-what-you-did#post-11063035" rel="nofollow">https://app.roll20.net/forum/post/11061146/not-sure-what-you-did#post-11063035</a>
1661824904
Thanks for helping out
1661898697
So, tonights game it was noticed that when my players were moving thier characters, the Token bars were actually moving first...then the character icon. Also.. Some players were not seeing hit point or AC updates.&nbsp; Ie: i would reduce Hit points but some players were still seeing max hit points. Roll20 is so gimped right now.&nbsp; Please fix this stuff.
They already admitted the LAGGING Issue and are already working on a fix! (As always no ETA) But since it is a GAME BREAKING bug and annoyance for everyone here on Roll20 it should be fixed soon! (My Assumption / Hope!) Tariff said: So, tonights game it was noticed that when my players were moving thier characters, the Token bars were actually moving first...then the character icon. Also.. Some players were not seeing hit point or AC updates.&nbsp; Ie: i would reduce Hit points but some players were still seeing max hit points. Roll20 is so gimped right now.&nbsp; Please fix this stuff.
1661903683
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Based on some early (now fixed) bugs, my guess is that the interface and the token itself are now two separate things (to allow for the hover feature). This does seem to explain the experience of moving one thing and the other following. (I have noticed this as well.)
1661927122

Edited 1661927135
keithcurtis said: Based on some early (now fixed) bugs, my guess is that the interface and the token itself are now two separate things (to allow for the hover feature). This does seem to explain the experience of moving one thing and the other following. (I have noticed this as well.) Let us not speculate about this and just wait until they roll out a fix for this. And let's also hope we do NOT have to wait a week or two before a fix is implemented!
1662486672
Ashton
Roll20 Team
We've fixed this issue but we're aware of an (unrelated) performance issue that we're actively working on a solve for. If anyone has a game that is still affected, please write into the Help Center with the following information: A link to the game where it is happening Does it consistently happen on that game? System information Browsers it happens on (along with versions) OS and version CPU, RAM, GPU Any effect of toggling Hardware Acceleration? Thank you!
keithcurtis said: Based on some early (now fixed) bugs, my guess is that the interface and the token itself are now two separate things (to allow for the hover feature). This does seem to explain the experience of moving one thing and the other following. (I have noticed this as well.) This actually explains a lot. Last night my friends were discovering a new issue where updated bars weren't staying updated, and if token and bars are considered separate entities, that might explain why that glitch has been occurring.
1662504799

Edited 1662505275
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
The token bar issue appears that it might be an entirely separate problem, since there are reports of it or something similar pre-dating the hover update.
1662527763
I just watched a streamed game on you tube where the group are also having issues with the token bars moving before the character icon AND the token bars not updating Hit Points etc.&nbsp; Not a good look for Roll 20 these kinds of bugs.
1663951820
We are STILL experiencing excessive lag on maps using fog of war.
1663954026

Edited 1663954040
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Tariff said: I just watched a streamed game on you tube where the group are also having issues with the token bars moving before the character icon AND the token bars not updating Hit Points etc.&nbsp; Not a good look for Roll 20 these kinds of bugs. Can you PM me a link to the streamed game?