Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

Teleport API needs constant token updates?

1663225790
Every time I add a new teleport page or a new link on a map I need to re-add all player tokens in order for it to function properly is there something causing this?  If I don't reset the tokens by deleting them from the GM layer and replacing on the new pages they simply go back to the gm layer and the player page does not change.  Example: I made links to all the buildings in LMoP map and got the character to move through all flawlessly then when i link that to the major map and added their tokens on there they would simply revert back to the gm layer and the player would not change pages.
1663227091
I never ran into such an issue - here are a couple of thoughts that might cause issues: The player-tokens need to be on the GM level of every page you want to teleport to. In case you are teleporting from the main page, this would happen automatically, in case you as GM move them, you need to ensure there is also a copy on the GM-layer. Therwise the teleport back would not work properly. I'd also check if all the teleport pads are configured correctly (after checking the tokens on the GM-layer). I you link a lot of pages, the list can become quite long an not easy to manage).
1663227887

Edited 1663228545
I have been testing it and making sure that the same tokens are on each page but if i make a new teleport link to a new page and back I have to delete all the token and re add it to both pages to get it to work again.  I am moving them from the player view so I can make sure they work each time.   Example:  Main map --> conyberry created add tokens then move back and forth perfectly.  Then add transport from Main Map --> Triboar and go and add them on the GM layer on triboar and they will not go I have to re add the tokens on the main page and then on the triboar page.  Also sometimes this then causes issues and then Main map -->conyberry no longer works.  I have made sure the links are correct even if my list is long I kept them very well labelled and created. Edit: It also seems to transport the last token i was moving around sometimes in its place.  Just tried again and triboar--> main map worked but when I did it in reverse main map --> triboar the token went back to the gm layer and on the triboar map the teleport token was now on the Token layer no longer on the gm layer