Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

URL links not working

1663946160
They have been broken for me for some timer. I used to be able to insert a link and they worked great. I can't get it to work in either Chrome or Firefox. Cache has been cleared. The text in the url link boxes is white, which is annoying.
1664448808
This sounds more like a CSS Error somehow. Have you gotten this error when disabling extensions too? Is this using Light Mode or Dark Mode? I personally do not recognize YOUR problem, though I've got a DIFFERENT “URLs not working” problem; perhaps additional information will help accelerate a way to solve whatever problem you are experiencing? Do you mean you cannot [text](URL), example: [Roll20](<a href="https://www.roll20.net" rel="nofollow">https://www.roll20.net</a>) or do you mean you cannot see a URL in Chat when just plain pasted into chat, like this: <a href="https://www.roll20.net" rel="nofollow">https://www.roll20.net</a> because, MY issue involves using a “(” or “)” in a [Text](URL) section's URL portion, because there are URLs one might want to link to cleanly where the URL includes a “(” or “)”, but the URL's “)” will break the URL Parsing Engine on Roll20; so, you might want to edit your Title to include a little extra description beyond just “URL links not working”.
1664460757
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
This likely refers to the display of text in the in-game dialog box for inserting a url while using dark mode. It displays as a very light gray on white. I have fixed it on my own computer with Stylus, but it is a bug that still needs to be corrected on Roll20's part. If you use stylus, it can be fixed with this code: .note-link-url.form-control.note-form-control.note-input, .note-link-text.form-control.note-form-control.note-input{ &nbsp; &nbsp; color: var(--dark-surface1, --color-surface2); } There are other issues related to this that still don't work properly, and there may be css hierarchies that keep it from being an easy fix. But the code above at least makes the URL input area visible. AviCat, let me know if you are interested in that code, but need any assistance in using it.
1664614884
Gacha
Plus
Just wanted to say that I'm having the same issues. I can't read the text in the URL link insert since they updated the fonts somewhat recently. Additionally, it seems to have broken some of the embedded rolls.
1664861865

Edited 1664876342
Reason for this Problem is 1 CSS line. If you remove that line, it is fixed. I highlight it in the following screenshot: I already sent a Help Center request so the devs are aware of it, pointed them to the thread with the solution and also attached screenshots for them. It should be only a matter of time until it gets fixed...
1664986436
I'm having the same "invisible text on URL entry" problem (light text on light background).&nbsp; Not using dark mode, am using Firefox. Until I found this thread, I thought I was doing something wrong, as it's been a while since I tried to enter a URL. Btw, if you click/drag in the text entry box, it will select and highlight the text, so you can see what's actually there.