Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

GM Toolbar - Fog of War selection operating wrong

1664289951
The Fog of War selection button on the GM Toolbar is acting like the Layer selection - Click, then click which sub-category (Layer vs Reveal). It should act more like the Drawing Tool button - Click - auto-select previous sub-category, override if another sub-category selected. I've heard way too many GMs complaining about the Fog of War button not working, and there's no reason not to default to the Fog sub-category that is displayed on the button.   Solution: One click on the Fog of War button should select it, with the last sub-category (reveal, hide, polygon) used.    
1664449082
+1 I legit stopped using Legacy Fog of War because of this specific problem; without Pro/Plus Membership, I just outright wouldn't use Fog of War in its current condition.
1664467348
Gauss
Forum Champion
I am not clear what the issue here is, could you please post reproduction steps? 
1664481863
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
I believe this references that when you click the FoW tool on the tool bar, you must select the sub tool each time. This is different behavior from the drawing tool for example, where clicking on it gives you the last selected tool. Click on a drawing tool, the base toolbar icon switches to that tool. Click on the FoW tool, you must select the sub tool. The icon doesn't change and you must select the subtool each time. It's slightly more cumbersome.
1664485641
it also sometimes just bugs out and refuses to work properly.
1664511404
What Keith said - it's a different functionality than most of the rest, and than makes sense for the tool.  It bugging out completely is a separate issue ;)
1664512199
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
I haven't had the bugging out experience.
1664514004
Andrew R.
Pro
Sheet Author
This is the original Fog of War that doesn’t care about UDL or LDL? I’ve been using it exclusively since 2014 with no trouble. I haven’t noticed it change since I last used it 2 weeks ago to setup a battle map for my 13th Age campaign.  I never use it during play or for anything other than Polygon Reveal however. 
1664537758
Maybe im clicking wrong but sometimes when i click to clear fog of war it instead draws fog of war
1664548877
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Likely a wrong click, but I'm not sure altering the behavior that the Majuba noted would prevent a mis-choice. Hmm... it would allow you to verify the specific tool you have chosen, though.
1664594488
or at least indicate better
Tariff said: Maybe im clicking wrong but sometimes when i click to clear fog of war it instead draws fog of war This bug happens to me more often then not (and it is a bug in my case, not a misclick) -- and it has been present for me since I joined Roll20 in 2020. Toggling to another tool or setting and back to Reveal Areas usually works eventually. The other workaround is to use Polygon Reveal instead of Reveal Areas.
1665521264
@keithcurtis, no, like @Sarah R. Cohen, I have had the same experience as @Tariff since I started using roll20 two+ years ago, and I play with two other DMs who have the same problem.  If you click on FOW, and then on reveal, about one time in 3 it selects hide instead (or, probably, simply fails to select reveal).  It's too frequent to be a misclick because I'm so used to it I usually look closely when clicking now. Maybe the hitbox is a lot smaller than the text or something, but I'm using stock CSS, no tweaks. It's something of a running joke with our players when we hide parts of the map they've already been to by accident.  I'd seen others comment on it, so I never bothered to report it, just assumed it was one of the many long-standing minor bugs that never got fixed. All three of us play without Dynamic Lighting, so that might be the issue.  I use Firefox (Mac), but one of the others uses Edge (not sure what the third uses, maybe Chrome).
1665535154
Same. I play using Dynamic Lighting; though, before I got Plus: this was HELL because the Show Tool frequently fails to actually Show, sometimes the Show Tool actually Hides, sometimes it just ceases to function; this was likely a compounded error stacked with Roll20's JavaScript Memory Leaks.
1665539254
Gauss
Forum Champion
I have also had FoW Hide the map even though Reveal was set.  I cannot provide repro steps though because it is random. But it seems to happen when I am switching to the reveal tool it doesn't "take". 
Gauss said: I have also had FoW Hide the map even though Reveal was set.  I cannot provide repro steps though because it is random. But it seems to happen when I am switching to the reveal tool it doesn't "take".  Me too! Wanted to reveal portions of the Map (Standard FoW) and instead it was set to hide... I remember this WAS fixed some time ago and indeed worked. Really Strange!