Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Can't Edit Maps

I have several map pages that I have already built. Now I can't add or remove anything from them. I can move the existing things around oddly enough. I am logged in as the DM and I've gone into all the layers and tried it, since I have items in all the layers already. I've tried logging out and back in, logging in as a player and then back to a DM, restarting my computer, updating chrome. I'm thinking it's some setting in Roll20 I don't know about? Any help would be greatly appreciated!!
Forum Champion
Have you tried a different browser?
Forum Champion
Marketplace Creator
API Scripter
Hi R.M.! There's another user reporting similar (but not identical behavior.  I'd suggest trying on a different browser (as Gauss suggests) and on a private browsing page. If each of those fails, see if you can drag in and older image and attempt to drag a non-working image, then copy the Console Log ( Chrome ,   Firefox ), and file a  Help Center Request . That's the best way to get the dev team the technical info they need.