Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

MagicMaster updated has dependency, stop mods loading

1664854337

Edited 1664854573
Hello, Please forgive me if I'm not posting this in the correct forum. I am having an issue with at least one of my mods working, and because the Mod Output Console seems to be .. different.. I thought I'd start here, since I believe other users are currently able to use the mod.  The one that I can tell is not working is ScriptCards, which has not had an update in the last 10 days.  It seems I am able to use other mods, such as Areas of Affect, Aura/Tint Health Tokens and It's a Trap; however, when I try to use anything associated to ScriptCards, I get no response; neither in the in-game chat window nor in the Mod Output Console, despite the same script or action working last week.  All in all, I'm not sure what might be going on, and kindly request your assistance with the matter.  I have reset the Mod Console, and while it says it's resetting, it seems different since last week when I previously used it.  It doesn't seem to mention the ScriptCards mod at all, as it's resetting. I have posted to the ScriptCards Discord in the event this is something introduced in the most recent update 11 days ago.  I did not update to that newest version until I noticed I was having an issue today, though.  Please let me know if there is any additional information that would be helpful for me to share. I look forward to no longer having the issue I'm having and thank you in advance for your time and help.  Kindest Regards, James ------------------------------------------------------- Restarting the Mod Console, this is the whole list of what it says (this seems to be 'incomplete' compared to my recollection of it from last week): Restarting sandbox by user request... detected currently running sandbox... restarting "It's A Trap!: Registered TrapTheme - default." "Loading character sheet data..." "Starting webworker script..." "Loading 922 translation strings to worker..." "Starting webworker script..." "Loading 922 translation strings to worker..." "-=> ChatSetAttr v1.10 <=-" "StatusFX: red -> splatter-blood [1,-1]" "StatusFX: green -> bubbling-acid" "StatusFX: sleep -> glow-holy" "StatusFX: stars -> beam-fire [2,3]" "DLdark v0.3 initialized." "-=> DoorKnocker v1.213 <=-  [Tue Dec 14 2021 16:59:11 GMT+0000 (Coordinated Universal Time)]" "-=> ShareVision v0.1.4 <=-  [Sat May 02 2015 13:04:12 GMT+0000 (Coordinated Universal Time)]" {"version":1.4,"vision":{}} "-=> Walls v0.3.7 <=-  [Fri Mar 25 2022 03:26:09 GMT+0000 (Coordinated Universal Time)]" "ŦŦ libInline v1.0.6, 2022/9/13 ŦŦ -- offset 6224" "   _____________________________________________       )_________________________________________(          )_____________________________________(                  ___| |_______________| |___                       |___   _______________   ___|                          | |               | |                              | |               | |                              | |               | |                              | |               | |                              | |               | |                ______________|_|_______________|_|_______________                                                    " "SmartAoE v0.25 initialized." "��������� Initialized World Map Discovery v1.1 ���������" "-=> ShortRest v0.1.1 <=-" "Roll20 Environment: Web" -------------------------------------------------------
1664859639

Edited 1664859805
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi James! You mentioned not updating to the newest version. Are you installing Script Cards manually? If so, have you tried disabling it and trying the OneClick install? (The "version" drop down does not actually do anything). To get the Oneclick to be available, you might need to rename the manual install. If you are using the latest released version, have you tried to see if it will load and work on a test game? FWIW, the Mod text that is not appearing is likely ""-=> ScriptCards - 2.1.11 by Kurt Jaegers Ready <=- Meta Offset : ...". Does this jibe with you?
1664879845
Hi Keith, Thank you so much for reaching out.  I did update to the latest version of ScriptCards manually, earlier today when I noticed things were being strange, but it didn't seem to cause any difference.  I got confirmation on the ScriptCards Discord that the OneClick should be current now as well.  I tried installing the OneClick version just now and I'm not getting different results with that over the manual install.  I don't remember the exact text I've seen before, when the ScriptCards mod loaded successfully, but the text you suggest seems logical and vaguely rings a bell (further note below). One thing that's really sticking out now that I've reset quite a few times is that there are no chat sounds during the reset process.  Normally I get quite a few pings of sound (like people are talking to me in chat, but I'm in another window).  Today, although the reset is occurring, there is not a single sound happening.  Not sure if that indicates anything, or might be something helpful to mention.  Kurt did confirm that his own Mod Console and installed version of the ScriptCards mod seems to be working fine.  Another user in his Discord mentioned something odd may be going on with the console, as they are not getting output to the console with a logging command within ScriptCards.  Not sure how much help this information is, but wanted to make sure I share. I created a new Test Game and installed only the ScriptCards mod, and it appears to be working in the test game!  The text you suggested appears in the mod console as well.  However, I'm not sure what that means for me in my "main game", as I'm not recalling any changes to list of mods I have for a few weeks now.  Here's what the console says in the test game after installing the ScriptCards mod: ------------------------------------------------------- Spinning up new sandbox... "Loading character sheet data..." "Starting webworker script..." "Loading 922 translation strings to worker..." "Starting webworker script..." "Loading 922 translation strings to worker..." "ScriptCards Triggers could not find character named \"ScriptCards_Triggers\"" "-=> ScriptCards - 2.1.11 by Kurt Jaegers Ready <=- Meta Offset : 3" "Roll20 Environment: Web" ------------------------------------------------------- Do you have any other thoughts/suggestions about what might be happening in my main game?  I really appreciate you taking the time to help me out, and I appreciate your patience with my new-ness. :) - James
1664881258
Edit:  It appears there is something wrong with MagicMaster mod.  A OneClick update just came out within the last day, and thanks to Kurt (from ScriptCards) I disabled that mod, and voila, everything else seems to have loaded right up!
1664885517
Kurt J.
Pro
API Scripter
Just a followup here - James has MagicMaster installed from OneClick, and the update last night/this morning went active, but part of the update appears to have been splitting lots of functionality into a shared library for all of the *Master addons, with libRPGMaster2e being listed as a new dependency for MagicMaster, Since the update process in OneClick doesn't add new dependency mods, removing and re-adding MagicMaster should auto-install the dependency and resolve the issue. It looks like the missing dependency was causing the API to crash without reporting anything to the console, so everything in the API list after MagicMaster was not loading.
1664892915
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Good detective work! I'm not familiar with the *Master scripts. Does something need to be communicated to Richard E, or to Roll20 to prevent this from happening to other folks?
1664911596
Honestly I think it would be a good idea to let people know they should remove the mod and then re-install it.  I'm not sure if there's a way to ensure that happens automatically, or to communicate this info broadly, but I don't think this is a "bad thing", so much as an "awareness item" for users who have these mods.  Perhaps I can update the title of this thread to something that would be meaningful if users are trying to solve this issue for themselves?  If that sounds like a good idea, I'd appreciate any suggestions to ensure it's as helpful as possible. :)
1664912100
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Only a mod can change the title. To get their help on this, just "Report" your top post, explain the reason and give the new title. (Even though you are reporting the post, you won't get yourself in trouble, it's just a way of flagging the moderators).
1664918130
Kurt J.
Pro
API Scripter
I posted in the rpgmaster thread and let Richard know.