Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

Windows 11, Firefox, Edge, Chrome can't paste anything into API window

1674319093
As the topic says. I can copy from a raw js window but I can't paste into the mod api window on any browser. I tried using incognito mode in Chrome and even that did not work. I copied it from Chrome and pasted it into Notepad++ then copied it from Notepad++ and tried to paste it into mod api window. It does not paste. Not sure how to fix this. Is there an upload mod or extension I can use to fix this? Any ideas?
1674319770
The Aaron
Forum Champion
API Scripter
There shouldn't be anything special about the textareas in Roll20's Mod Sandbox, can you paste in other online forms from Windows 11?  How about if you create a new game, can you paste scripts into that one?  The fact that the issue isn't tied to a particular browser makes me think this is something wrong locally, like a policy for the current user.
1674319927

Edited 1674320005
Scott C.
Forum Champion
Sheet Author
API Scripter
Compendium Curator
Hmm, I can't replicate your issue. Can you share a screencap of the area you are trying to paste into? And maybe a link to the code that you are trying to paste in? EDIT: Sniped by Aaron!
1674326483
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Hi Glenn! Did you press the New Script button first, to generate a pasteable window? It sounds like you might be trying to paste into the log window, which is read-only.
1674606378
I am trying to paste in the black section underneath where the "monster.js" is. Paste is lit up when I try but nothing happens.
1674607582
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
I can't replicate this either, sorry. Can you paste in there when using a different browser?
1674774296

Edited 1674774516
Oosh
Sheet Author
Can you type in there directly? Another thing you could check is to right click on the blinking cursor and hit 'Inspect Element'. In the dev tools, the inspector should show a bunch of elements including a <textarea>: You might need to drill down a couple of divs, depending on exactly where you clicked to open the inspector. If you leave that open and try pasting again, does the <textarea> momentarily light up or highlight? The <textarea> handballs its input off into a <div> for each line on every @input event fired, then clears its own value. If those <divs> aren't being created it would just look like the text doesn't appear (or flashes up for a fraction of a second). I can't think of anything that would cause this across multiple browsers though (unless they're all really old browsers).
1674930767
I can type in there. I do see a text area. <textarea class="ace_text-input" wrap="off" autocorrect="off" autocapitalize="off" spellcheck="false" style="opacity: 0; height: 12px; width: 6px; left: 43px; top: 0px;"></textarea> I was able to paste it into here. Weirdly enough, I was also able to paste it in there. I took just a small section of the script I was trying to paste and was able to paste it in. I just can't paste the whole script for some reason.
1674931363
I went a few steps further and found that I can copy and paste in very small sections. It is terrible and takes forever to paste in the script but it can seemingly be done. I am maybe 40% through. I am thinking there is some security setting or something preventing this. It must be in Windows 11 because I could not paste the full script in Chrome, Edge, or Firefox. I will get this pasted in then keep looking to see. Maybe Microsoft forums have an idea of what might be blocking it.
1674932493
GiGs
Pro
Sheet Author
API Scripter
Just to be clear, can you post in the New Script box here?
1674932704

Edited 1674932793
GiGs
Pro
Sheet Author
API Scripter
Having read through the post it does look like you have a problem. Here are some things you must try if you havent already: Try a different browser. If you're on Firefox, try Chrome, and vice-versa. Try in an incognito window (CTRL+SHIFT+P if on firefox, It might be CTRL+SHIFT+N on chrome). Create a new user profile in your browser, and try again. (Methods vary between firefox and chrome, and can be complex). It sounds like you might have a browser extension causing problems, or some other kind of browser bug - sone ore more of these should fix that. I cannot emphasise enough: the problem you are having is not normal, and something is creating that problem.
1674952447
Oosh
Sheet Author
Have you got any kind of OS-level antivirus or anti-malware type software running? As GiGs said, it's certainly not something Windows-standard causing this, or most users would be having the same problem.