Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Compendium monsters only show with default token when dragged into game

Hi, I've been trying to start DMing with roll20 but whenever I drag monsters from the compendium onto the board, it only shows the default blank character for their tokens and I have to manually change it in the edit section, I searched this issue up and it seems a popular fix is to wait for the popup window to fully load, I tried doing that but it does not fix my issue at all. I also tried changing browsers but that didn't fix it either.
Have you paid for a compendium (such as the D&D 5E Monster Manual) or are you just using monsters that are part of the SRD (System Resource Document; what is open source and free to everyone)?  The SRD does not include images. You would have to pay for a Roll20 compendium that includes images (such as the Monster Manual, or Volo’s Guide to Monsters, or other sources if you’re playing games other that D&D 5th edition). 
Forum Champion
Hi Axerfen,  To add to what Jarren wrote, if you could take a screenshot of the compendium when you search for a creature, we can tell you if it is SRD or not.  If it is an SRD creature, after adding the image to the token, make sure you hit the "Update Default Token" button.