Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Games will not launch after latest update

What it says on the title. I'm using the latest version of Firefox, but nothing will launch.
Forum Champion
Hi Jimmy,  Could you supply more information? What happens when you try to launch your game?  Is this in a regular game or a Jumpgate game?
It's in a regular game, where it just gets stuck at the loading screen after I try to launch it.
Forum Champion
Have you tried a Private tab?  Have you tried logging out and then logging back in? 
David M.
API Scripter
I had this happen for one of my players a year or two ago (getting stuck on loading screen). Ultimately, I tried making a copy of the game and she was suddenly able to load. I renamed it and we just migrated to the copy. Might be worth a shot for you have run out of things to try.

Edited 1711861499
Forum Champion
Jimmy, are you the Game Owner or a player in the game? 

Edited 1712013345
Marketplace Creator
I had this same issue two weeks ago. It took a couple hours, but it fixed itself. I tried clearing cookies, rebooting. Everything I could think of. It just suddenly started working. Was during a streamed game, so my viewers did not have a map for a couple hours. Edit: It wasn't my internet connection either. Edit: Just before Jumpgate.