Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account

API unresponsive

1424641670
Will
Pro
So here we are again: one week later and mid-session and the API scripts have become completely unresponsive again. Same exact issues and symptoms found in this thread: <a href="https://app.roll20.net/forum/post/1612378/api-halt" rel="nofollow">https://app.roll20.net/forum/post/1612378/api-halt</a>... What can I do to help the Devs troubleshoot this?
1424642557
Steve K.
Roll20 Production Team
Sheet Author
API Scripter
Compendium Curator
What's the URL to your campaign?
1424642849
Will
Pro
<a href="https://app.roll20.net/campaigns/details/544657/mu" rel="nofollow">https://app.roll20.net/campaigns/details/544657/mu</a>... You mean that url, or the player invite address?
1424643289
Will
Pro
Just looked at the API page, and it seems to be spinning up a sandbox every few minutes. I have disabled all scripts except for power cards. We are trying the cards at regular intervals during play and every once in a while a card will work.
1424647065
Will
Pro
So now when the cards work for a few minutes, they populate 2-4 copies each, sometimes 20-30 seconds after the first and interspered with other power cards.
Having the same problem in mine: <a href="https://app.roll20.net/join/370710/XYo9vA" rel="nofollow">https://app.roll20.net/join/370710/XYo9vA</a>
Unfortunately my weekly game is entirely based on powercards. Hopefully we can get a resolution to this before next week since this just cancelled this week's game :(
The api server has been really unstable today, even on the DEV server. With the API page open it was restarting the sandbox very frequently and often while waiting for it to come up, the API was unresponsive.
1424653793
Steve K.
Roll20 Production Team
Sheet Author
API Scripter
Compendium Curator
We just restarted the API server, let us know if the problems persist.
1424654593

Edited 1424654664
On the DEV server it still seems to be cycling: Restarting sandbox due to script changes... Spinning up new sandbox... Spinning up new sandbox... Spinning up new sandbox... Restarting sandbox due to script changes... Spinning up new sandbox... Spinning up new sandbox... In this case I did press the save button twice, initially to give it a kick... then again when it went unrepsonsive. Edit: It's currently spitting out doubles as well.
1424655131
Will
Pro
Problem was still existent 5 mins ago when we called our session quits. We would get 1 random power card out of 20 and it would populate in the chat window 2-3 times then stop working.
1424655328
Riley D.
Roll20 Team
I think I tracked down the issue. Let me know if you have a problem from this point forward.
1424656389
Riley D.
Roll20 Team
I take that back, the fix I thought would work is not working, I'll keep working on it.
1424657460
Riley D.
Roll20 Team
Okay, as they say, "This time, for sure."
Looks quite positive, from a mentor who relies very heavily on the great API scripts, thank you for your attention to this late in a weekend.
1424660601
Will
Pro
Looks good, thanks for the effort you put into this guys!