Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account
This post has been closed. You can still view previous posts, but you can't post any new replies.

Campaign won't load, constantly refreshing page upon launch.


Edited 1445906532
Hi, I'm having the same issue with my campaign loading as&nbsp; this post .&nbsp; I took a quick .gif of it here;&nbsp; <a href="" rel="nofollow"></a> (The campaign is The Gorveil Hunting Grounds) I also know how the issue started (Or at least I presume so); I like keeping things neat and generally we have players in our campaigns stop in for a few sessions then have to bow out for a long time before they can return. So while I was sorting out the campaign settings I decided to cut down the huge list of people that had joined the campaign and set it back to only the current active players. So I went though and kicked the inactive players to get our current player count down to what it actually was. I don't believe I was logged into the game itself during this time, but I also don't believe the campaign was inactive. I get the feeling that with the new update that now makes it refresh the Roll20 page whenever someone is kicked someone got hooked into an endless loop trying to refresh the page and then checking if all players currently connected had refreshed, which possibly returned negative since no players were actually connected at all. Perhaps it only checked upon the first restart after the kick, so any subsequent restarts didn't actually have any validation. Just a guess, however that's how the issue came to be at least. Hope someone can resolve this issue soon, many thanks in advance! Update #1&nbsp; Here's the Support Details information . Update #2 Occasionally I seem to be able to get into the campaign either through sheer luck or by rapidly switching tabs during the loading process (I'm guessing due to Chrome's don't run certain features on an inactive tab functionality). It'll let me into the campaign, but if I try and exit and join again the issue starts back as it was before. Additionally my players are having the same issue as I am. I also had one of my players test getting kicked and rejoining the campaign, which didn't solve the issue. Update #3 Issue seems to be resolved. Not sure quite what caused the fix, perhaps it was one of you nice chaps. Regardless, I seem to be able to join the campaign without any problems now.

Edited 1446083717
Kevin the Barbarian
Sheet Author
API Scripter
I had this problem - on multiple computers even. Solved it by clearing my Roll20 cookies.
The issue that was plaguing my campaign wasn't specific to my own computer. In fact, it was shared by not only myself but all of my players. During the time of fault nobody could log onto the campaign without being forcefully restarted by Roll20 itself. The resolution that worked for us was that occasionally by switching between tabs at random points during the initial loading of the campaign (Before the Chat Log loads) occasionally (Read 1 in 20-30 tries) I was able to avoid being forcefully restarted. I believe it has something to do with Chrome's functionality to not 'play' certain scripts unless the tab is in focus. However, while that allowed me to get into the campaign by sheer luck, it didn't stop the problem from happening. Reloading the page led to the problem occuring again. I actually, or at least seemed to, fix it by loading the page in a second tab. So without reloading the page that I managed to finally load the interface, and leaving it open in one tab, I opened it again in a second tab. From there on it decided that it was actually okay with loading the campaign. Now, that seems like a really strange way for the problem to be fixed and I would actually be more inclinded to think that perhaps it was a side-effect of some of the actions, or perhaps accidentilly during that process of events I might have triggered something else. Perhaps even a Dev was kind enough to stop by and fix the issue, forgetting to post that they had resolved it in this thread. But either way, that was the sequence of events that led up to the issue being resolved.
Gen Kitty
Forum Champion
Before we dive into the guts of the issue, we're going to need you to do a few things for us, things that sometimes fix issues for users before more extensive troubleshooting is needed. Can you please follow Steps 1-3 of our Solving Technical Issues checklist (confirm you're using the latest non-test version of Firefox or Chrome; turn off all extensions, addons, and anti-virus; and clear your cache) to see if one of those components is causing the problem? We can only help if we can recreate your issue, so it is important that you follow each step. If doing that fixes the issue, just let us know. Otherwise, move on to Step 4 , and we'll need all that information, in addition to a link to the game (in the form of <a href="" rel="nofollow"></a> , not a join link) to further assist you.
Problem has already been resolved, as I updated in the main post. Thank you for your offered assistance though!