Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Create a free account

API sandbox shutdown due to campaign inactivity.

1376970647
Lithl
Pro
Sheet Author
API Scripter
My output console is reporting this, and it's extremely frustrating. I can't figure out how to restart the sandbox; performing actions in the app, refreshing the page (app and scripts), and clearing the chat archive (from inside and outside the app) don't seem to count as "activity", as far as this problem is concerned. Help?
1376991784
This usually happens because you haven't done anything in the app for awhile or do not have it open. I usually open the API scripts in one tab and the app in the other. As long as you're saving the api scripts as you work, it shouldn't shut down.
1377004245
Riley D.
Roll20 Team
The sandbox is only run when someone is actually in your game. The script editor is just for editing the scripts, the sandbox is what actually runs them. Ideally, as HoneyBadger said, you probably want a tab open with your game and another tab open with the script editor, so that you can be testing your scripts while you're editing them. If you're just coding and don't need to do any actual testing for some reason, you can just ignore that message, and the next time your campaign is accessed a new sandbox will automatically be spun up.
1377020606

Edited 1377020653
Lithl
Pro
Sheet Author
API Scripter
That's just it-I first became aware of the problem when a player tried to use API command in one of the scripts, and it didn't do anything. I opened up the editor to check the log, and found the message. I had two players and myself in the app, with the editor open in another tab, and it didn't start back up.
1377142719

Edited 1377155943
Lithl
Pro
Sheet Author
API Scripter
I currently have 3 campaigns that I've created; one has no scripts (a campaign planned for the future), one is my testing ground for developing scripts (currently contains 1 script), and one is for an actual campaign (contains 4 scripts). When I created this topic, both campaigns with scripts were reporting the problem (the campaign without scripts is reporting that it's got no scripts, as expected). Since then, the testing ground campaign has started working again, but the sandbox for the actual campaign is still shut down, despite activity from multiple users. EDIT: Finally, after three days, the sandbox started up again. I've no idea what went wrong. hopefully it doesn't happen again.
I have this same issue one one of my campaigns I'm getting ready to start.
Is the campaign open? and if you GM multiple campaigns, are you sure your API window is the right one for the campaign?
Something is going on because I am using the Star Wars Edge of the Empire dice script and now its not working.... Anyone know whats going on? I have a session to run Sunday morning! Thanks 
As far as I can tell everything is just as it was this morning when it was working with my campaign; using the Star Wars EotE dice script. I even tried coping my campaign to dev and adding the script to no avail.
1379141073
Lithl
Pro
Sheet Author
API Scripter
Two of my campaigns are suffering from this problem again. =( One is the Betrayal at House on the Hill port that I'm working on; not a big deal since it's far from complete, but I was hoping to test my stun/unstun command for monsters today. The fact that my sandbox is having issues just means I'll work on some other aspect instead. The other is my Cutie Mark Crusaders Troop #185 campaign which is having "Session Zero" in ~14 hours. It doesn't have much scripting in it, but one of the API commands I'd added let players create their own character, and set a bunch of defaults automatically, so if it still isn't working by the time people start making characters, I'll have to create the sheet and there will be much more fiddling than otherwise. The campaign I use for testing the larger scripts I write for others in this forum is still working. The campaign for my Sunday D&D game isn't having this issue, but the console does say "Restarting sandbox due to script changes..." and none of the scripts are currently functioning.
I'm also having trouble in one campaign, but another campaign, running identical scripts, has no trouble.
1379188755

Edited 1379189102
I will second what Rand said. I have one campaign where everything is working and one that the Sandbox wont startup in. It says the API shutdown due to inactivity just like Brian. I copied the campaign and the new one works just fine.
1379191837
I have one campaign where the API is not working due to inactivity. I have another campaign where permission is denied. This is making my Saturday games rather old school / stone age... lol.
1379217479
Lithl
Pro
Sheet Author
API Scripter
Obviously, once all of the players in my new campaign were done making characters, that's when the campaign's sandbox spun up again, allowing my character creation API command to function. Of course. /facepalm
1379222364
Pat S.
Forum Champion
Sheet Author
I've been using the api in my play by post games and they have been working sporadically it seems like.
1379225317
There must have been a problem with the API server earlier. Riley sent me a message about one of my campaign API problems being fixed and so was the other one at around the same time.