Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

"My Library" files still not actually being deleted when many are selected at once

Since I first joined roll20, I've had issues with getting files deleted. I can't recall the amount of times that I've selected 10+ files, hit "delete", and Ok'd the confirmation, only to find that those files would be back in my library a few hours later, because the deletion simply didn't work. Right now, my library seems so massive that going through it all to tag the unorganized mess feels like a daunting task that isn't worth my time. I'd very much like to start my library over from scratch at some point; uploading files from my computer folder by folder after having pre-organized them with naming conventions and folder structures. If I can't batch-delete large groups of files, I'll be wasting a lot of my Roll20 Library upload allotment. It's not a big deal for me at the moment, because I have a Pro account, but Free users and users who have a lot of large assets could be majorly hindered by this issue.
Kristin C.
Roll20 Team
As a first measure, could you double check for me that there isn't something interfering with Roll20's processes: Could you please carefully work through the first three steps of our guide to Solving Technical Issues ? Step 1: Make sure to use the right browser Please check if these issues persist when using both Chrome and Firefox. Step 2: Ensure that there are no extensions/addons interfering with Roll20 Please disable all add-ons/extensions and anti-virus programs. Step 3: Clear your cache If none of the above succeeds, please thoroughly work through Step 4 . (Don't forget the complete Console Log!)

Edited 1476118612
Step 1: Using the latest version of Chrome for this example, though I've used Firefox 47 before with no extensions on, but JS active. I'm running Ubuntu 15.10, with no antivirus. Step 2: Disabled AdBlock and Scriptsafe, my only Chrome extensions. Step3 & Step4: I completed the console log linked below once before clearing cache, and then once again after clearing cache. I went through 3 cycles of deletion attempts: New, broken images. Older, also broken images. Much older, non-broken images. Below is a zip archive with screenshots of the process, showing the deletion attempts, and then time-lapsed reloadings of the page (ending with a deletion attempt with [switching to roll20 main, clearing cache, and then returning to My Library] included), showing that the files don't appear to have been deleted. <a href="" rel="nofollow"></a>... Here's my Chrome console log: <a href="" rel="nofollow"></a>...

Edited 1476855895
Has there been any progress on this? I seem to still be experiencing the same issue today. I seem to be able to effectively delete 7 or so rows without a problem, but more than that results in nothing being deleted. I've tried with Firefox again, with all extensions disabled. Edit: I decided to take the time to delete my library one "loading page" at a time. It took over an hour, but at least it's done. I still hope to hear that something is being done to enable users to mass-delete items more efficiently.
Kristin C.
Roll20 Team
My apologies for this getting lost in the shuffle. Was the mass deletion an issue that you had within the application (in a game) itself or was it just with the My Library website page?
Just the My Library page.