Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Advertisement Create a free account Compendium in Game, Join Today

[Bug] Reversed Template Helper Function Display in Chat Archive

1487655958
Elena S.
Sheet Author
I'm having an issue with how one of my roll templates is displaying in the chat archive when using the #^rollWas Crit() helper function. It displays properly in the game room, but does not display properly in the Chat archive. The only time I'm seeing this discrepancy is with this particular helper function. Screenshot from inside the game room: Screenshot from the Chat Archive: This is my console log from Firefox: Custom Sheet Translation chatloglibs.js:5:5250 Initializing new dice engine with randomness... chatloglibs.js:6:24553 Using random entropy chatloglibs.js:6:24630 Custom Sheet Translation chatloglibs.js:10:14222 Compiling sheet... chatloglibs.js:10:15129 Found rolltemplate: 2Edefault chatloglibs.js:10:15412 Found rolltemplate: 2Eattack chatloglibs.js:10:15412 Found rolltemplate: 2Espell chatloglibs.js:10:15412 Found rolltemplate: 2Esave chatloglibs.js:10:15412 Finding sheet rolls... chatloglibs.js:10:16047 Use of attributes’ nodeValue attribute is deprecated. Use value instead. chatloglibs.js:10:18077 Use of getPreventDefault() is deprecated. Use defaultPrevented instead. jquery.min.js:2:40278 Loading mixed (insecure) display content “<a href="http://imgsrv.roll20.net/?src=i.imgur.com/rFM5RnH.png”" rel="nofollow">http://imgsrv.roll20.net/?src=i.imgur.com/rFM5RnH.png”</a> on a secure page[Learn More] jquery.min.js:2:39252 Loading mixed (insecure) display content “<a href="http://imgsrv.roll20.net/?src=i.imgur.com/QFPPKuq.png”" rel="nofollow">http://imgsrv.roll20.net/?src=i.imgur.com/QFPPKuq.png”</a> on a secure page[Learn More] jquery.min.js:2:39252 autograv chatloglibs.js:10:23706 Here's the Console Log from Chrome: chatloglibs.js:5 Custom Sheet Translation chatloglibs.js:6 Initializing new dice engine with randomness... chatloglibs.js:6 Using random entropy chatloglibs.js:10 Custom Sheet Translation chatloglibs.js:10 Compiling sheet... chatloglibs.js:10 Found rolltemplate: 2Edefault chatloglibs.js:10 Found rolltemplate: 2Eattack chatloglibs.js:10 Found rolltemplate: 2Espell chatloglibs.js:10 Found rolltemplate: 2Esave jquery.min.js:2 The specified value "@{basespeed}-[[@{basespeed}*1/3]]" is not a valid number. The value must match to the following regular expression: -?(\d+|\d+\.\d+|\.\d+)([eE][-+]?\d+)? clean @ jquery.min.js:2 jquery.min.js:2 The specified value "@{basespeed}-[[@{basespeed}*1/2]]" is not a valid number. The value must match to the following regular expression: -?(\d+|\d+\.\d+|\.\d+)([eE][-+]?\d+)? clean @ jquery.min.js:2 jquery.min.js:2 The specified value "@{basespeed}-[[@{basespeed}*2/3]]" is not a valid number. The value must match to the following regular expression: -?(\d+|\d+\.\d+|\.\d+)([eE][-+]?\d+)? clean @ jquery.min.js:2 jquery.min.js:2 The specified value "@{gearweighttotal}+1-1" is not a valid number. The value must match to the following regular expression: -?(\d+|\d+\.\d+|\.\d+)([eE][-+]?\d+)? clean @ jquery.min.js:2 jquery.min.js:2 The specified value "@{HP}" is not a valid number. The value must match to the following regular expression: -?(\d+|\d+\.\d+|\.\d+)([eE][-+]?\d+)? clean @ jquery.min.js:2 jquery.min.js:2 The specified value "@{HP}" is not a valid number. The value must match to the following regular expression: -?(\d+|\d+\.\d+|\.\d+)([eE][-+]?\d+)? clean @ jquery.min.js:2 chatloglibs.js:10 Finding sheet rolls... 1566076:1 Mixed Content: The page at '<a href="https://app.roll20.net/campaigns/chatarchive/1566076" rel="nofollow">https://app.roll20.net/campaigns/chatarchive/1566076</a>' was loaded over HTTPS, but requested an insecure image '<a href="http://imgsrv.roll20.net/?src=i.imgur.com/rFM5RnH.png" rel="nofollow">http://imgsrv.roll20.net/?src=i.imgur.com/rFM5RnH.png</a>'. This content should also be served over HTTPS. 1566076:1 Mixed Content: The page at '<a href="https://app.roll20.net/campaigns/chatarchive/1566076" rel="nofollow">https://app.roll20.net/campaigns/chatarchive/1566076</a>' was loaded over HTTPS, but requested an insecure image '<a href="http://imgsrv.roll20.net/?src=i.imgur.com/QFPPKuq.png" rel="nofollow">http://imgsrv.roll20.net/?src=i.imgur.com/QFPPKuq.png</a>'. This content should also be served over HTTPS. Thanks for your help! Elena
1487656336

Edited 1487656700
Not sure why it's doing that, but just wanted to say that's a sweet looking template.
1487656479
Elena S.
Sheet Author
Lol, thanks.
1488482239

Edited 1488482265
Kristin C.
Roll20 Team
Hi Elana, Could you tell me what sheet these templates are for and provide code samples for the template that is glitching in the log? Thanks Also, do you have a test game in which to see this in action?
1488502784

Edited 1488503253
Elena S.
Sheet Author
Yes indeed, They are the new templates I made for the Dungeons and Dragons - Advanced 2nd Edition (Simple Sheet) for resolving weapon attacks. The Beta game for the sheet can be found at <a href="https://app.roll20.net/join/2014880/Vnfrtw" rel="nofollow">https://app.roll20.net/join/2014880/Vnfrtw</a> . And the related code: &lt;rolltemplate&gt; &lt;div&gt; &lt;div&gt; &lt;table&gt; &lt;tr&gt;&lt;th&gt;{{title}}&lt;/th&gt;&lt;/tr&gt; &lt;tr&gt;&lt;th&gt;{{subtitle}}&lt;/th&gt;&lt;/tr&gt; &lt;/table&gt; &lt;/div&gt; &lt;div&gt; &lt;table&gt; &lt;tr&gt;&lt;td colspan="3"&gt;&lt;span&gt;{{weapon_used}}&lt;/span&gt;&lt;/td&gt;&lt;/tr&gt; &lt;tr&gt;&lt;td&gt;&lt;b&gt;S/M&lt;/b&gt;&lt;/td&gt;&lt;td rowspan="2"&gt;{{ac_hit}}&lt;/td&gt;&lt;td&gt;&lt;b&gt;L&lt;/b&gt;&lt;/td&gt;&lt;/tr&gt; {{#^rollWasCrit() ac_hit}} &lt;tr&gt;&lt;td rowspan="2"&gt;{{dmg_s}}&lt;/td&gt;&lt;td rowspan="2"&gt;{{dmg_l}}&lt;/td&gt;&lt;/tr&gt; &lt;tr&gt;&lt;td&gt;&lt;b&gt;AC Hit&lt;/b&gt;&lt;/td&gt;&lt;/tr&gt; {{/^rollWasCrit() ac_hit}} {{#rollWasCrit() ac_hit}} &lt;tr&gt;&lt;td rowspan="2"&gt;{{crit_s}}&lt;/td&gt;&lt;td rowspan="2"&gt;{{crit_l}}&lt;/td&gt;&lt;/tr&gt; &lt;tr&gt;&lt;td&gt;&lt;b&gt;AC Hit&lt;/b&gt;&lt;/td&gt;&lt;/tr&gt; &lt;tr&gt;&lt;td colspan="3"&gt;CRITICAL HIT!{{#crit}}&lt;br&gt;&lt;span class='attack-crit'&gt;{{crit}}&lt;/span&gt;{{/crit}}&lt;/td&gt;&lt;/tr&gt; {{/rollWasCrit() ac_hit }} {{#rollWasFumble() ac_hit }} &lt;tr&gt;&lt;td colspan="3"&gt;FUMBLE!{{#fumble}}&lt;br&gt;&lt;span class='attack-fumble'&gt;{{fumble}}&lt;/span&gt;{{/fumble}}&lt;/td&gt;&lt;/tr&gt; {{/rollWasFumble() ac_hit }} &lt;/table&gt; &lt;/div&gt; &lt;/div&gt; &lt;/rolltemplate&gt; As I said, the templates display perfectly in game, but not in the chat archive. The code above that is in bold italics is what doesn't appear to display in the chat archive.
1490034437

Edited 1490034460
Kristin C.
Roll20 Team
Hi Elena, My apologies for taking so long to get to this. I had to do some CSS digging to investigate what was wrong. Comparing the HTML of the weapon attack roll template between in-game and archive, the third row of its table is missing in the Chat Archive. It's not display hidden. That final row is completely missing from the HTML. You may want to double check to make sure your table tags are closed properly for that roll template. The in-game chat has the ability to auto-close inproperly closed HTML, but this sort of logic isn't available in the archive as it's just displaying a log.