This post has been closed. You can still view previous posts, but you can't post any new replies.

All npc's sheets > set to Always whisper to DM.

This is very straightforward, I don't know what has changed, how it changed but somehow all my formerly hidden rolls as npc creatures and such are now being shown to players!  This is all in wizards of the coast resources.  I just want a Game setting I can choose so everything that's not a player can be set to "whsiper to dm only" rather than currently, where I have to SELECT EVERY SINGLE SHEET AND CHANGE IT'S SETTING!!! X_x 
1506348607
As a pro subscriber, you have access to the API which could do this for you.
Kyle G. said: As a pro subscriber, you have access to the API which could do this for you. I am a pro member but how no idea what the API is :o what is this?
Luke S. said: Kyle G. said: As a pro subscriber, you have access to the API which could do this for you. I am a pro member but how no idea what the API is :o what is this? I'm getting error messages about my game API >_<
1506349554
These error messages are just because you have not used API scripts on that game. When you restart the API server, this error will go away. As to which script to use to change the whisper setting, I recommend Jakob's ChatSetAttr script. It will allow you to directly make changes to a character sheet (NPCs as well) through chat commands (or macros). If you let us know which character sheet, we could probably even give you the command you want to change the whisper setting.
so it's ALL NPC'S :P The key problem is (spoilers)  Azaka stormfang is a guide in tomb of annihilation but they are secretly a lycanthropath.  When she does an attack roll, the title of the attack the players see, is her name being a tiger lycanthropath, spoiling that surprise :P  So it's just just one thing, it's to all enemy rolls basically. giving away all the details :P
1506357218
You could change the game default settings globally in game settings -> game default settings -> Default sheet settings, save, go into the game and in the cog section (not the sheet but the VTT), down at the bottom under experimental features -> Apply Default settings, click on all the boxes for settings you want to apply, say yes to the warning box and it will change ALL the sheets. Then you only need to change the PC sheets back manually.
1506357317
Luke S. said: so it's ALL NPC'S :P When she does an attack roll, the title of the attack the players see, is her name being a tiger lycanthropath, spoiling that surprise :P  So it's just just one thing, it's to all enemy rolls basically. giving away all the details :P If you are using the 5e OGL character sheet, the next version (v 2.0) will have an option to hide the name in the roll templates.
also I did restart it. I still am getting error downloading scripts. (which makes sense as I have none)  but It hasn't gone away like you said either :P  I found your API script you reccomended and going to see what changes it gives
Kyle G. said: Luke S. said: so it's ALL NPC'S :P When she does an attack roll, the title of the attack the players see, is her name being a tiger lycanthropath, spoiling that surprise :P  So it's just just one thing, it's to all enemy rolls basically. giving away all the details :P If you are using the 5e OGL character sheet, the next version (v 2.0) will have an option to hide the name in the roll templates. That's cool but mostly I just want my gm rolls to stay secret without typing /gm I roll all these as a gm so I don't know why macro's keep these hidden without adding "/gm roll" so i'm at a loss :P 
1506357875
Yea, that error is a 'no issue' error. I don't think I have ever seen it unless I have no added scripts to a game.
Doug E. said: You could change the game default settings globally in game settings -> game default settings -> Default sheet settings, save, go into the game and in the cog section (not the sheet but the VTT), down at the bottom under experimental features -> Apply Default settings, click on all the boxes for settings you want to apply, say yes to the warning box and it will change ALL the sheets. Then you only need to change the PC sheets back manually. trying this now......hazily :P
Luke S. said: Doug E. said: You could change the game default settings globally in game settings -> game default settings -> Default sheet settings, save, go into the game and in the cog section (not the sheet but the VTT), down at the bottom under experimental features -> Apply Default settings, click on all the boxes for settings you want to apply, say yes to the warning box and it will change ALL the sheets. Then you only need to change the PC sheets back manually. trying this now......hazily :P Seems promising!
YES!!!! THIS HAS EXACTLY DONE THE EXACT THING I WANTED IT TO!!!!  THANK YOU SO MUCH FOR YOUR GUIDANCE!!! ;W;
1506443988
Trivia
Roll20 Team
Yay, I'm glad this was resolved! Closing thread to refund votes :)