Maps don't show up for me

1507044945
Hi, I started building the world for a new Ars Magica campaign. I added a few maps, changed them to drawings, and added them to the map layer. I did this a couple of days ago and everything was fine, but now they aren't showing up for me anymore. Even weirder, I am able to see some  of them in the preview on top. Here is a screenshot:  noMaps I use Google Chrome on Windows 10. But I tried switching browser to no success. I had them open yesterday and the whole weekend and there weren't any problems. I really want to solve this before I start to extending the world for obvious reasons :)  Any help would be appreciated. cheers, Pasuht
Same here. Seems to be the same issue as  here and  here
1507051803

Edited 1507051845
Same problem here. Had no trouble during the weekend tho. Tried different browers, checked my network connection and cleared the browser cache. No changes. Besides myself a few of my players are experiencing similar problems. While one doesn't even have a single problem at all.
1507104775
One way or another it seems solved. My maps load normal again. If anyone read this or one of the other posts and did something, thx!