Tablet support

My group and I have recently jumped on the roll20 train for our DnD game, we bought the storm king's thunder campaign and paid a plus membership to our DM so we could use all the feature of the app. Tablet in hand we tried to play with the tablet support hoping to control our character on the map and see our own vision of the map, but 3 of us with different tablets, and none worked. It all crashed while trying to load the map, took forever to load the UI then see a bit of the map, then crash, every time. We dont own state of the art tablets, but i think its odd that none worked. Mine is an Acer Iconia one 10 quad core 1.3ghz 1gb ram. Android 6.0 Using chrome Any idea on how to make this work would be appreciated
1507229238
Drespar
Roll20 Development Team
Hi  Maxime D. , Does this issue persist if you load up a brand new game? Additionally, could you please carefully work through to the first three steps of our guide to Solving Technical Issues : Step 1: Make sure to use the right browser Please check if these issues persist when using both Chrome and Firefox. Step 2: Ensure that there are no extensions/addons interfering with Roll20 Please disable all add-ons/extensions and anti-virus programs. Step 3: Clear your cache If none of the above succeeds, please have your player thoroughly work through Step 4 . (Don't forget the complete Console Log!) Thank you!