Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Pulling from MM not working


Edited 1507498006
I pull up an entry "poisonous snake" from the MM1 (which I have purchased in Roll20).  When I grab the creature and pull it to the TT, nothing happens.  It doesn't place a token onto the table for me. I pulled an alhoon from Volos Guide and I got a message about experience from my xp script. and it rolled hp for the alhoon and after about 45 seconds DID pull him onto the VTT.
The Aaron
API Scripter
There were some issues earlier with the servers, possibly it was taking a long time?  I just tried it from my copy of the Monster Manual and it worked.  Be sure you're dragging the name to the table, not the icon: