I cannot upload any pictures

I have used roll20 for like 4 years and i have never, ever had any problems with it. But now for some reason, everytime i try to upload an image it just shows a blank loading bar that stays there for eternity. I have tried everything, i turned off my AVG, i cleared my browser cache(Chrome), tried firefox, i tried deleting my storage space and still nothing. I am getting really frustrated with this shit, i have used it fine for years and never had this problem. 
I'm a new user and I also can't upload image. There is the same error in console (compendiumBase). I tried in different browsers and different images (small and big, jpg and png) - no matter what I choose, there will be always the same error.
Wow well atleast i am not the only one. If i can't get this solved by tomorrow then i will have to leave roll20 for good, go to maptools instead. Its a bit harder to set up but it doesn't hae major problems like this. 
1512506333
Bast L.
Pro
API Scripter
Interesting, I could upload in a game, but not to the game's page (the picture for the game). It was the same picture too, a small png file.
1512508914
Drespar
Roll20 Development Team
Hi everybody, I am seeing this behavior as well, but only on the banner for a campaign. Are you experiencing this anywhere else?
I am getting this even on my profile pic. All pictures i cannot post basically.
1512511983
Drespar
Roll20 Development Team
A fix was just pushed out for this issue, so you should be able to upload a profile picture as well as a banner image. Let me know if you have any further issues!
1512513951
i have the same problem i cant drop any picture in my library like i used to
1512516732
Drespar
Roll20 Development Team
Marian S. said: i have the same problem i cant drop any picture in my library like i used to Are you having trouble adding pictures to the library itself (dragging images to the tabletop should automatically add them, as well as using the upload feature)? Or are you having trouble dragging images from the library onto the tabletop?
Ok things are fixed for me thanks. Have a game in two weeks.
Yup, it also works for me. Thank you.
1512677391

Edited 1512982042
Hello, sadly it does not work for me - only on campaign banners though ! Observed on Chrome 62.0.3202.94 and Safari 11.0.1 (and some unknown version of Firefox) on OS X High Sierra. Same console logs as for the original poster. Seems like `d20.compendium` is undefined :/ EDIT : Somehow, it now works ! Don't mind me, I'll be on my way now RE-EDIT : For anyone who comes across this post experiencing the same issue, the fix is just to wait and let the page load for a little bit more. I figured out it's just a question of loading time.