Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account

[PF] Macro working in one campaign, not in another

Hello all~ Thanks in advance for any help on this issue! I am using the Pathfinder sheet in game (the one named just Pathfinder), and using it alongside the excellent companion script for it. I have probably.. six games set up like this, and a favorite macro of mine is to use group roll macro: !pfc --grouproll,roll=?{Roll|Initiative,initiative?{Sort or Clear|Sort,,sort|Clear,,clear|Neither,}|Fortitude Save|Reflex Save|Will Save|Acrobatics|Appraise|Bluff|Climb|Craft|Diplomacy|Disable Device|Disguise|Escape Artist|Fly|Handle Animal|Heal|Intimidate|Knowledge Arcana,Arcana|Knowledge Dungeoneering,Dungeoneering|Knowledge Engineering,engineering|Knowledge Geography,geography|Knowledge History,history|Knowledge Local,local|Knowledge Nobility,nobility|Knowledge Planes,planes|Knowledge Religion,religion|Linguistics|Perception|Perform|Profession|Ride|Sense Motive|Sleight of Hand|stealth|Survival|Swim|Use Magic Device|Misc} I grabbed the macro from the script's documentation:  Script Companion So it works great, but I wanted a group roll for secret rolls. So, according to the companion document, all I have to do is add ',whisper' to the end. And it works GREAT... in *one* campaign only. I can't seem to reproduce it at all and there is my problem. Even if I copy/paste the same macro to this other campaign, it refuses to work.  If I copy and paste directly from the document, and test the macro before saving it.... it works. But as soon as I save the macro, and if I either test or use it any other way, it will not show all of the options. Below are screenshots to illustrate. In order: 1st image is a brand new macro, copy and pasted macro text. 2nd is the test macro output, selecting a character token, and how it SHOULD look. Then we have the macro text after 'save changes' - it formats the text a bit, but in my other campaign (where it works) it does the same thing and that doesn't seem to be a problem. The fourth image is the macro output. And with that output, if I select 'initiative', THEN I see the menu for all of the other skills/saves I can roll.... but then it rolls them as initiative??  So.. I apologize for a bulky post, but I have literally no idea why this isn't working correctly and I'd really appreciate even a second pair of eyes on it! Thank you again!
1521430783
The Aaron
Forum Champion
API Scripter
I'm pretty sure this is an issue with HTML Entities getting substituted at the wrong point.  I know it will change things if you edit it after you've saved it.  I don't know much about the Pathfinder Character Sheet or Companion script, but I know people that do, I'll ping some.    In the meantime, I'd suggest trying recopying it from the source document (and do that each time you want to edit it, as the entities get replaced on save, so you can't really edit it), making your changes once and saving.  It's also a good idea to copy the working text from the macro before saving it, and store that in a text file elsewhere for easy copy/pasting.
1521434609
Scott C.
Forum Champion
Sheet Author
API Scripter
Compendium Curator
Yes, this is indeed an html encoding issue. I heghly recommend storing your macros that have html entities in hem in a character ability (just make a character called macros) which don't do this auto replacement.
Thank you both for such a quick response, I did make it into a character ability and it works perfectly. I'll keep that in mind for the future!!! Thanks so much for the help!
1521493375
Scott C.
Forum Champion
Sheet Author
API Scripter
Compendium Curator
Glad you got it figured out. Also, sorry for the horrible autocorrect induced spelling.