Advertisement Create a free account

Macros doesnt work anymore

1528968027

Edited 1528968156
Hey guys, suddenly none of my macros work anymore. was something changed? here's an example of a simple one &{template:default} {{name=@{selected|token_name} Tries to block}} {{blockroll=[[1d20+@{block}]]}} all of them worked without problems before, pls help
Does anything happen at all when you use the macro? What happens when you enter the macro in the chat after selecting a token? Is the @{block} attribute something that comes from the selected token you're referencing or from somewhere else? If this is the case this macro should do what you're looking for: &{template:default} {{name=@{selected|token_name} Tries to block}} {{blockroll=[[1d20+@{selected|block}]]}} If this doesn't work, could you check whether the token you're selecting is associated to a character sheet?
1528970340

Edited 1528971075
i only get purple bars in the chat the block attribute is set in the journal entry and the token is assosiated to it (in german its called Abwehr) the command is a token action (so the link to the journal entry works) i tried your changes but still only get the purple bars in chat here's a picture of the journal entry, the token actions and the chat https://ibb.co/kfT12y
1528973938
GiGs
Pro
Sheet Author
Try deleting your chat archive, from the campaign page (you might want to save a copy first).
1528976076
Ziechael
Roll20 Mod Team
Sheet Author
API Scripter
Hi Yeti, As G G says, a game's creator is often able to fix issues with their Text Chat by clearing the Chat Archive (note: not clearing your current Chat Log ). A GM might want to copy/back up the Chat Archive before the creator clears it.
ok, it fixed the problem. thx a lot ;)