Image distort problems

Why when i follow the wiki instructions to create a map object ( I created a vectorial, simple computer screen to test into rolld20) , my object get distorted ? I want it to fit into the square grid ( Which is supposed to be 70 x 70 pixel ,  i fail to see the logic of how could a 140 x 140 pixel could fit properly into that.. ) .  I made the image in a 140 x 140 pixels as suggested , 72 dpi .  I created the image in PNG , for transparency purpose. I draged and drop the said object from my library into Roll20 map. So here are the two results i got : 1. I drag and drop the object into the token layer : My object get squished and enlarged from top to bottom . 2. I drag and drop the object into the map layer : My object is enlarge and now fits into 3 squares intead of 1 . Is there any ways that i can get it to fit into only 1 square as it should be
1531325510
keithcurtis
Roll20 Mod Team
Could you post the actual image? It might help in order to figure out what's going wrong. The image upload process to the forums has been kind of wonky for the past few days, so it might take several tries. (BTW, if your image is 140 px by 140 px, the "DPI" is an illusion. Its just 140 pixels.)
1531325582
The Aaron
Pro
API Scripter
DPI doesn't actually matter, just the pixel size.  The suggestion of 140x140 for a unit square is so it looks crisp at 200% zoom (the maximum zoom in Roll20), at which point it will be "actual size".  There are a few things you can do to size your graphic: With the graphic on the table top selected, drag one of the corners until it's the right size. Right click the graphic on the table top and choose Advanced->Set Dimensions, then put in the pixel size.  Alternatively, you can change the dropdown to Units and set the dimensions you want it to have on the grid. You can hold Alt while dragging an image out of your art library to preserve it's aspect ratio.  You'll still need to change it's size. (Hold alt while resizing to prevent it from snapping to the grid) Can you post your test graphic?
Yes it is 140x140 pixel. Yes i will try to post my image , if the forum will work :P
1531325734
The Aaron
Pro
API Scripter
I haven't been able to get the drag in image to work on the forum, but the Picture button (second from right) has worked for me, as long as I used it before typing any text in the post.
1531325792
The Aaron
Pro
API Scripter
Ok.  Your image is 176x57 pixels.  Wherever you created it, you need to adjust the canvas to be square and re-save it.
Thank you , i thought my canvas was save with the transparency . Well it might explain why :P
Thank you for your time  it works now ! Its a good community :) Sorry about this , i should have looked at my image size before posting . I feel kind of stupid now  :P Thanks
1531327698
The Aaron
Pro
API Scripter
No worries, it's not the least bit obvious!  We only know because we've been at it for soooo long. =D
Well , thank you :) I just forgot that i needed to export the file with the artboard , because if i dont il will crop the excess with illustrator.
1531331094
Brian C.
Pro
Marketplace Creator
As a side note, you can add a non-square image. Turn off the grid on the page. Drop the image on the correct layer. Right-click the image and select "Advanced->Is Drawing" from the menu. Turn the grid back on.
Good to know , thank you :D