Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account

Microphone stopped working

1393777187
Samuel Penn
KS Backer
I ran my first roll20 session on Friday night, unfortunately after about a month of everything working fine whilst testing, the microphone stopped working about 15 minutes before the game started, and I haven't managed to get it working since then (I ran things by also being logged in via my laptop, and used the microphone on that, which wasn't ideal). I'm running Chrome on Linux (KDE/Ubuntu 13.10), using WebRTC. The camera works fine (it's a USB webcam which has phone/camera built in), and the microphone works fine in other applications (e.g. Google Hangouts) or on another machines, it just refuses to work within Roll20 on my desktop. I've tried wiping Chrome's cache (I've also restarted the machine etc). I've tried disabling/enabling video chat in Roll20. The same webcam works fine on another PC. As I said, it was working perfectly fine, until Friday night when it stopped working for no apparent reason. Any ideas on what I can try next to fix the problem? Thanks, Sam.
1394137630
Samuel Penn
KS Backer
Doesn't anyone have any ideas as to why it's stopped working, or how to get it working again?
1394138695

Edited 1394138919
Were you only having problems in Chrome? Did you only experience the issue with WebRTC or did it cause the same problem in Flash/Google hangouts? TokBox does offer some diagnostics tools for troubleshoot issues: <a href="http://tokbox.com/user-diagnostic/" rel="nofollow">http://tokbox.com/user-diagnostic/</a> They have some more sophisticated tools as well: <a href="http://tokbox.com/opentok/support/diagnostic-tools/" rel="nofollow">http://tokbox.com/opentok/support/diagnostic-tools/</a>
1394146483
Samuel Penn
KS Backer
It doesn't seem to work in Firefox at all (Firefox hangs when video starts). Flash doesn't seem to work on either desktop or laptop (I get a dialog asking to give permission, but I can't click Allow). It works fine in Google Hangouts in Chrome everywhere. The TokBox diagnostics tell me that I have to use Windows, which isn't helpful. On their test session, the video works but I get no sound from my desktop. Video and sound from the laptop works fine. I've tried removing all tokbox cookies and disabling and re-enabling Chrome's webcam access, and checked ALSA settings for capture (which shouldn't matter, since it works in Hangouts). The same webcam works on my Chromebox, so I may have to run tomorrow's game from there, but that means going back to a small monitor so I'd rather get it working on my PC. Thanks for the links, at least it gave me something to try, but I'm still no further ahead.
1394155722
Riley D.
Roll20 Team
When you click the little "Camera" icon in the top-right corner of Chrome, does the Mic show up in the list and just not work when it's selected? Or not show up as an option?
1394182019
Samuel Penn
KS Backer
It shows up, it just doesn't work. It's almost as if it's muted, but it's not (at least, the mute option isn't selected, and I've tried muting/unmuting to verify). The microphone selected is the one for the webcam (I have other options, such as the PC's sound card, but I don't have a mic attached to that).