Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account

Inserting URL for "Choose a File" causes Chrome to Aww, Snap and crash. I have to reload Roll20.

1551848801
This has been happening for a while now. I have the previous and latest Chrome. Window 7 I can drag and drop uploaded files fine, but if I open, say, a Note (Anything that lets me import a pic)and click CHOOSE A FILE, then I paste the URL to a small .jpg lets say (Doesn't seem to matter which file type I choose), Chrome goes Aww Snap and crashes, then I have to reload Roll20. The NEXT time I click the CHOOSE A FILE BUTTON, I get a popup error say "Open File - You can't open this location using this program. Please try a different location.". and "H7hEmgK0umc" appears as the filename, which isn't the URL I posted, obviously. If I restart roll 20 the popup isn't there and the filename is not filled in.. only after I do it once, it fails, and I refresh Roll20. I didn't see anything else in the forums about this so I guess its just me?
1551857452
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
"Choose a File" is for uploading from your hard drive, or dragging an image from your library. The only place you can paste a URL is with the Picture link button in a forum post. Unless I am misunderstanding your post.
Hi Roland, please let us know if the above helps so we can determine if you're experiencing a bug.
1551896195
I've been using the "Choose a file" button for years to directly uplink files from the internet. Granted it doesnt work if the site is protected like imgur or pinterest, etc.. but it's been working for me for years until fairly recently, with the UI overhaul. Does it work for you? I've been doing it this way for character portraits and handouts since 2014. Maybe its not supported but does it work for you? 1) Copy Image URL ( I used&nbsp; <a href="https://i.ebayimg.com/images/i/171815659260-0-1/s-l1000.jpg" rel="nofollow">https://i.ebayimg.com/images/i/171815659260-0-1/s-l1000.jpg</a> &nbsp;but anything thats not being a signup screen should work) 2) Create a new Handout 3) Click the "Choose a File" Button 4) Paste the URL int he "Filename" field. I've successfully used long and short URLs, png and jpg.. doesnt seem to matter in the past) 5) Click open. The window closes and a second later Chrome crashes with an Aw Snap! The new "Mystertious Note" is there but no image since it crashed. 6) Open the note = get an instant popup saying You cant open this location using this program Please try a different location. &nbsp; &nbsp; &nbsp; The Filename is garbage (&nbsp;171815659260-0-1) 7) Here's the Chrome crash report: IMPORTANT: Your crash has already been automatically reported to our crash system. Please file this bug only if you can provide more information about it. Chrome Version: 72.0.3626.121 Operating System: Windows NT 6.1.7601 SP1 URL (if applicable) where crash occurred: Can you reproduce this crash? What steps will reproduce this crash? (If it's not reproducible, what were you doing just before the crash?) 1. 2. 3. ****DO NOT CHANGE BELOW THIS LINE**** Crash ID: crash/97f765b433884dbf
1551896505
Since the filename ends up being "171815659260-0-1", which was part of the path I uploaded, I'm guessing Roll20 is dropping the text after the last slash and before the next to last slash. Were I to hazard a guess, slashes are no longer able to be used as part of a filename.&nbsp; Images I've uploaded in the past still work, the images are still there and opening the Handout or Character isnt a problem.
1551900318
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
If I click the Choose a File button, I am presented with a file selection dialog box. I have no "Filename" field to paste anything into. Admittedly, I either use Chromebook or Mac. Perhaps this is a feature of the Window's file selection dialog?
1551907089
Its a standard Windows [7] FIle Dialog Box, yes. I guess we'd need a someone with a similar setup to see if the problem can be reproduced.
1551907387
I just tried it on a different, never reproduced PC (Win 7 CHrome) and the same thing happened. I am no longer able to upload pics into Roll20 directly via URL.&nbsp;
I just followed your steps using Firefox (64-bit version 65.0.2) and it worked fine for me. Have you tried Firefox? Or maybe you have an add-on or extension in Chrome that is causing problems? Have you tried this in an Incognito window in Chrome?
1552058804
Drespar
Roll20 Team
Hi Roland, So we did a bit of digging and it seems to have been a change on Chrome's end. This feature worked witch Chrome v71 but began to fail starting at v72. As Rabulias stated it does still function with Firefox to our knowledge. Keep in mind that this is not a feature that we necessarily support but more of an extension of Windows OS that allowed this behavior. We will be looking into why this is causing a hard crash, but we would still recommend using the methods described here:&nbsp;<a href="https://wiki.roll20.net/Art_Library#Uploading_Art" rel="nofollow">https://wiki.roll20.net/Art_Library#Uploading_Art</a>
1552065553
Thanks everyone for checking into this! Updates: Disabling Extensions still doesnt fix it I hadn't tried InGognito so I did and that doesnt fix it Works in Firefox I downgraded Chrome to v71 and it is working again. Definitely something in the chrome v72 upgrade as suggested. I'll keep this version. When playing and coming up with stuff on the fly, uploading a URL is so much faster than saving the file and then uploading it the official way.&nbsp;
1552065765
vÍnce
Pro
Sheet Author
Try running Chrome as Administrator.&nbsp; I had a similar issue with Chrome where it would lock the browser whenever I tried to upload a file through the browser.&nbsp; Changing the shortcut to run as Administrator fixed the issue for me.&nbsp; Be warned, that it may be a security issue running your browser as such.