Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
D&D 2024 has arrived! Pre-order the new core rulebooks now and get an exclusive pre-order bonus for free!
Create a free account

Jukebox does nothing


Edited 1553340981
Hi all I'm trying to add some sound effects to my dungeon but nothing is happening. I can click on one of the four tabs, type in a search in the "Search for" dialogue box (like 'dungeon' for example), but that's it. When I hit Enter, nothing happens. Nothing at all. No busy icon spinning - absolutely nothing at all happens.   What am I doing wrong?
Can you post a screenshot please?
That's it. It doesn't matter if I scroll down, hit enter, or anything. 
Have you tried in both Firefox and Chrome?
Just tried it and the exact same thing happens. I do a search, I press Enter, and all it does nothing at all. 

Edited 1553361162
Does it happen on the BattleBards and the Incompetech tabs too? When you click the tabs, before you search you should see tracks listed. EDIT: Also, try disabling all browser extensions and add-ons.

Edited 1553426751
I do see the listings but as soon as I type in anything (like dungeon or rainfall), it all disappears. EDIT: Ah...I see how it works now. It works a little differently to how usual search engines operate.  Thank you for your help.