Advertisement Create a free account

Was there and API update?

1575095343

Edited 1575095382
DXWarlock
Pro
Sheet Author
API Scripter
I have not touched my scripts since a few days ago and they was working fine. But now I get an error trying to use the PF community sheet script for conditions of: TypeError: templates.button is not a function. This works yesterday, and I have not touched that script itself in many many months. Trying to narrow down if its isolated to me and something funky in my games/scripts or a change that broke it.
1575096973
DXWarlock
Pro
Sheet Author
API Scripter
Seems a false alarm. No idea what was wrong. Disabling all my scripts one by one, and re-enabling them all fix it. No clue how, I didn't change anything just disabled and enabled..but I won't look a mysterious gift horse in the mouth :)
1575129827
The Aaron
Forum Champion
API Scripter
Strange.  templates.button is a function in DryErase, MutantYearZero, Observer, ColorEmote, PageNavigation, and PFC.  It could be that it corrupted in your running version of the scripts some how, and so disabling and restoring them caused it to become fixed.
1575145637

Edited 1575145709
DXWarlock
Pro
Sheet Author
API Scripter
It is strange. And I dont like being one of the ones to use the old disliked axiom "It was JUST working" with no helpful information of what changed, but I hadn't a clue of anything that did...haha Why I was perplexed. After the error digging around seeing if accidentally typed a key while in the API window, saving over and over, disabling all scripts but that one and testing and still getting it..To disable it itself after posting as a 'can't work any less' concept and it worked when I turned it back on..then turned all the others on and they worked. Without changing any of them. Chalk it up to Roll20 Gremlins.