Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account
This post has been closed. You can still view previous posts, but you can't post any new replies.

Help - APIs not working

Something popped up that my APIs weren't working. I clicked to restart them, and now nothing is happening. it says shutdown was completed and starting up, but never moves from there. Im really new to this and don't know why its happening.
Forum Champion
Marketplace Creator
API Scripter
Is the game up and running concurrently? If so, you have verified that the API scripts are doing nothing?
I did. Thank you for the reply. I had a roommate that does scripting for a living take a look at it and he got it working again for me. Thank you again
Hi,  Not sure what is happening with the API scripting Pages, However on the output console all I am seeing is a blank box.  I am using the latest version of google chrome - but have tried in Microsoft Edge (latest version) as well.   As you can see form the image below - there are only two scripts on this game, which is my test game before moving the scripts onto my live game!  I am not sure what the issue is and have tried this with just a single script from The menu too with the same result! 
I'm having the same issue as Mayenar, which I've posted about here , and still have no fix or explanation for it.
I just started a game and am having the same issue.
Blank output box. No API running at all.
do you have a window with the game launched? I have found that the APIs will not initiate unless the game is currently launched.
Yes thanks, currently running in another browser window.
Sheet Author
The only thing I have seen cause that (for myself anyway) is if you have some sort of privacy/security addon that is blocking  You might check to be sure nothing is interfering with that.  For myself, whenever the NoScript addon for Firefox updates, it has a tendency to undo some things I had previously set as trusted, including sometimes shutting down while logged into a game, which locks out the api.

Edited 1591046519
I restarted and am still experiencing very strange behavior. API sandbox is blank for all four of my current games and restart button does nothing. However, in three of the four the API is actually working while in the fourth it is not. I am using Chrome and have no privacy/security addon active. Weird.
I'm having the same issues.  It looks like my API sandbox is locked hard.  I can't restart the sandbox or even delete scripts to troubleshoot if one is causing the issues.  APIs work on another game I am a player in, so I think its something in my account only.  I've tried all the usual steps; cleared chat log, logged out and back in after restarting web browser, try to restart sandbox (no response), tried to remove scripts one at a time (no response).
Same here since the recent API update. 
Me too. 

Edited 1591069868
I am having the same problem. The API has stopped working. I am using Shaped 5e and when I used the apply token defaults command it killed the API. Rolling back the game doesn't work either.
I Too still have these problems. :/ maybe it's a precursor to them shutting down the site for 30mins tomorrow?? 0_o  But yeah would like some updates when a dev has time. 
It doesn't look like the maintenance fixed the issue I'm having.  Anyone else still having problems with the API still being hung up?
Bast L.
API Scripter
I'm having some strange behavior, maybe very delayed (minutes) saving/loading of the sandbox, not really sure.

Edited 1591106216
Still having these problems. No api loading on any campaigns, can't reset sandbox... seems tied to account. Tried from different computers and different browsers.
It might also be per campaign.  I made a copy of my campaign and it seemed to work better.  I added back in most of my scripts and they seem to be ok.  Haven't tested them all but the Bump script definitely was not working on both old and new campaigns and the API console is still unresponsive, so I'm hesitant to say this is a work around.
I'm having the same issue with a 5E game with the OGL Sheet and multiple other API scripts. Scripts all worked fine for the last 2 weeks, yet API console stopped running without any changes I made. I believe they stopped working Saturday, which aligns with some work the Roll20 team did on the API servers (as announced on their twitter and forums).  I've also run the game on multiple computers, incognito mode, with and without a VPN, no browser addons, and different browsers (Chrome, Firefox) without success. Searched around and done everything I can think of but I'm convinced I've not caused the issue. Scripts work on one new game that I made The error I receive that I think? is causing the issue is this one: "  Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval' 'sha256-dm6tOb8rwEmENe5+ec26sQvlH6Xd1CBZ7IvtZ4kJ1og=' 'sha256-jlxVUPsj/qdPM120UwbjpC4Tw7dq+obb7SYUV+lSfrI=' 'nonce-2LOZpvbgBWazMm3w'" " Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval' 'sha256-dm6tOb8rwEmENe5+ec26sQvlH6Xd1CBZ7IvtZ4kJ1og=' 'sha256-jlxVUPsj/qdPM120UwbjpC4Tw7dq+obb7SYUV+lSfrI=' 'nonce-2LOZpvbgBWazMm3w'" My API output console is completely blank, API's don't work in-game, again I don't think this is anything I've done or the fault of an API. Clicking on Restart API Sandbox or Enable/Disable Scripts throws the following error: 4690355:6 Uncaught TypeError: Cannot read property 'child' of undefined at HTMLButtonElement.<anonymous> ( 4690355:4710 ) at HTMLButtonElement.dispatch ( v2.js?1590064647:51 ) at HTMLButtonElement.g.handle ( v2.js?1590064647:51 ) at HTMLButtonElement.nrWrapper ( 4690355:6 ) (anonymous) @ 4690355:4710 dispatch @ v2.js?1590064647:51 g.handle @ v2.js?1590064647:51 nrWrapper @ 4690355:6 For reference, here are the scripts I'm running: Also my location is UK, in case this is a location-based issue. Only bought pro recently, and finally finished setting up the API's, only for them to not work for the weekends D&D game. Obviously this is very frustrating and I hope someone can provide a solution to this issue as I'm pretty stumped.
I am very happy to have switched to Foundry, and no longer have to endure this kind of annoyance.
Roll20 Team
Hey folks -  Would you mind providing me with links to the games experiencing the issue, please? We're investigating this right now. Thank you for your assistance and patience.

Edited 1591115800
This is a copy of the original game: <a href="" rel="nofollow"></a> This is the original game rolled-back to before the problem: <a href="" rel="nofollow"></a> This is a new game I started setting up yesterday that does not have the bug: <a href="" rel="nofollow"></a> The API stops working when I use the apply defaults command for the Shaped5e script. I have not tried the apply defaults in the Experimenttal Features. I haven't used the apply defaults command in the third game and everything is working fine.
API Scripter
I had a game last night and it was working fine until about 9:20 pm EST and then the API just died and like everyone else reporting no more output. Game Link: <a href="" rel="nofollow"></a>
Roll20 Team
Hey everyone -&nbsp; Thank you for the links! We have identified a regional issue with certain Javascript assets that is causing a problem with the API scripts page and the external journal. We’re currently investigating and working on a fix. To keep messaging organized and consolidated, please follow the main thread for updates,&nbsp; seen here . As such, we're going to be closing this post.