Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Advertisement Create a free account Compendium in Game, Join Today

Roll20 Performance Issues

1610499720
Roll20 seems to be having some issues right now where maps are taking forever to load and trying to drag new things onto the map is taking forever.  Anyone else seeing this problem?
1610536087

Edited 1610538782
Yeah have the same Problem since yesterday. The maps get stuck in an blurry/fuzzy unsharp mode during loading. HavenĀ“t install anything new to my browser and already checked  add ons and anti virus software.
1610544252
I am also experiencing this situation. I used to use Microsoft Edge (Chromium) yesterday, before making a switch to Mozilla Firefox. It slightly helped me, however this is not the cookie cutter performance one would think they'd be getting at the usual silver times of Roll20. It must be related to some Amazon server-side performance overload, or perhaps some dev/api features of Roll20 take up all of the bandwidth and that leaves us with nearly nothing? Who knows. Either way, another symptom of this is that marketplace packs download at the speed of 10-15 kB/s.
1610566389
It seems to be working alright now, might have been some sort of cloud hiccup or something.
1610575070
Nick
Pro
I'm also experiencing this issue. Exact same issue on Firefox or Chrome, doesn't matter which I try it on. The blurry map issue really sucks.