Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Advertisement Create a free account Compendium in Game, Join Today

GM Whisper macro not working properly

1614035588
Hi there, I have created a nice macro along with tables to get a daily 'weather' report and cannot seem to get it to go to GM only in normal use, but it goes to a GM whisper in the test macro. any ideas?  /w gm &{template:default}{{name=Weather}}={{**Wind= [[1t[Weather]]] [[1d8]] **Hours** **Windstorm Bonus:**[[1t[hurricane]]] Light WInd **[[1d10+10]] mph** Moderate Wind **[[1d10+20]] mph** Strong Wind **[[1d10+21]] mph** Severe Wind **[[2d10+31]] mph** Windstorm **[[3d10+41]] mph**}}{{**Temperature**=[[1t[Weather1]]]**[[1d3*3]]'C**}}{{**Precipitation**=[[1t[Weather2]]][[1d8]]**Hours** **Light Precipitation:** [[1t[light]]] **Medium Precipitation:** [[1t[medium]]] **Heavy Precipitation:** [[1t[heavy]]] **Thunder Hours [[1d3]]**}}{{**Thunderbolt Chance**=[[1t[thunder]]] **DC15 [[10D6]]}}
1614040501
Kraynic
Pro
Sheet Author
You generally can't have line breaks in a macro.  Some templates have been written with a description or notes section that can handle line breaks, but the default template can't.  Once you are past the name, every time you want a new line or grouping in the output, you would need to put it in another double set of curly brackets. So, everything you have above needs to be in one continuous line.  You might think about putting more groupings of brackets, like the light, medium, and heavy precipitation.
Hmmm... the default template should be fine with line breaks as long as they're inside {{ template properties }}. Do you have a closing brace }} or anything similar in any of the roll table results? Does it post the entire thing to public chat, or does it start at a certain point in the macro? If I rename all the tables in your macro, it whispers in chat OK.
1614090751
Kraynic
Pro
Sheet Author
Oosh said: Hmmm... the default template should be fine with line breaks as long as they're inside {{ template properties }}. I guess it does.  For some reason, I had it stuck in my mind that you couldn't do that with the default template at all.  That'll teach me (again) not to post without testing.
1614110582
Oosh said: Hmmm... the default template should be fine with line breaks as long as they're inside {{ template properties }}. Do you have a closing brace }} or anything similar in any of the roll table results? Does it post the entire thing to public chat, or does it start at a certain point in the macro? If I rename all the tables in your macro, it whispers in chat OK. No I do not have any closing braces within the tables; Weather: No WInd Light Wind Moderate Wind Strong Wind Tiny Severe Wind Small/Tiny Windstorm Medium/Small Weather2: No Precipitation Light Precipitation Medium Precipitation Heavy Precipitation Weather1 Normal Temperature 20'C Colder Temperature 20'C- Hotter Temperature 20'C+ light: Light Fog -2 Perception & -2 Ranged Medium Fog -4 Perception & -4 Ranged Drizzle -2 Perception Light Rain medium Medium Fog (-4 Perception & Ranged) Heavy Fog Rain (-4 Perception & -4 Ranged heavy: Heavy Fog Heavy Rain -6 Perception & -6 Ranged Thunderstorm hurricane: Hurricane No Hurricane Tornado thunder: No Thunderbolt Thunderbolt Are the full entries for the tables, I have added the colons to differentiate the tables
1614111877
GiGs
Pro
Sheet Author
API Scripter
What do you mean by this: cannot seem to get it to go to GM only in normal use, but it goes to a GM whisper in the test macro I'm not following something. You have it working in a test macro? Why cant you se that for "normal use"?
1614113139
GiGs said: What do you mean by this: cannot seem to get it to go to GM only in normal use, but it goes to a GM whisper in the test macro I'm not following something. You have it working in a test macro? Why cant you se that for "normal use"? When the macro is enabled 'in Bar' and then pressed, it sends the information to the general chat, rather than solely to GM as a whisper, I logged in with a secondary account to confirm. Yes I could use it for normal use if needed, was just asking if anyone could suggest any ideas, as it seems like a bug
You have a space in front of the /w When pasted into chat that space would get trimmed so the whisper works in testing. But in a macro that leading space remains so doesn't pickup the whisper command.
1614115132
RainbowEncoder said: You have a space in front of the /w When pasted into chat that space would get trimmed so the whisper works in testing. But in a macro that leading space remains so doesn't pickup the whisper command. Hahaha, it's always the little things that get missed xD, thank you so much!