Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
Advertisement Create a free account Compendium in Game, Join Today

Icewind Dale: ROTF. ALL token names are visible for players.

1614421725

Edited 1614421934
Hey. I'm honestly not sure if this is a bug, or if this is my own ineptitude for missing a easy option. But here's the gist of it: Every single token in the newest adventuring module Icewind Dale: Rime of the Frostmaiden has their name visible to all players. And I'd rather not go into each individual token on every single map to change these settings. (Or have this issue happen in future campaigns if this is a setting when making a campaign) Usually this isn't a problem, however in some cases it can be very spoiler-y and immersion breaking. (Such as the encounter in Bremen on the lake, figuring that out just cause of a token name is a bit of an anti-climax). Did I miss some option? Or is there something else going on?
1614464353
Check the token defaults in the Game Defaults section of the Game Setting page. Make sure the player permission for 'See' Name is un checked. Set up everything else as how you want it. Save and then launch the game In the settings tab near the bottom, is an "Apply Default Settings" button. Click on that and it should change all the tokens permissions, etc.. However! Use with Caution! Make a copy of the game first and try the changes on it to make sure there are no surprises.
Doug E. said: Check the token defaults in the Game Defaults section of the Game Setting page. Make sure the player permission for 'See' Name is un checked. Set up everything else as how you want it. Save and then launch the game In the settings tab near the bottom, is an "Apply Default Settings" button. Click on that and it should change all the tokens permissions, etc.. However! Use with Caution! Make a copy of the game first and try the changes on it to make sure there are no surprises. Hey Doug, I'm seconding Rez' question. The only settings visible in this particular module are the Character Sheet options. There are no default token option to apply, even if I did set the correct default settings in the game settings...
1614543158
Kraynic
Pro
Sheet Author
Sebastiaan A. said: Hey Doug, I'm seconding Rez' question. The only settings visible in this particular module are the Character Sheet options. There are no default token option to apply, even if I did set the correct default settings in the game settings... You need to click on the "Game Default Settings" label to expand the default settings for map pages and tokens.  Does that show up for you?
Kraynic said: Sebastiaan A. said: Hey Doug, I'm seconding Rez' question. The only settings visible in this particular module are the Character Sheet options. There are no default token option to apply, even if I did set the correct default settings in the game settings... You need to click on the "Game Default Settings" label to expand the default settings for map pages and tokens.  Does that show up for you? Hi Kraynic, I'm afraid you're misunderstanding. I did find that menu and those settings are set as I prefer. This does not update any of the tokens that came with the module though. There IS an option in game that says "apply default settings", but the token settings do not seem to be an option in that menu, only the character sheet settings. See my screenshot below.
I'm having this issue too and the default settings already have the setting turned off. The only way to fix it seems to be to go into the token manually to both disable the name plate and delete the name. If you don't delete the name, it shows up in the turn order. It's very problematic and ruins every reveal unless you fix it manually during prep... please fix this. It hasn't been a problem in other modules. 
1614987091
Kraynic
Pro
Sheet Author
Sebastiaan A. said: Hi Kraynic, I'm afraid you're misunderstanding. I did find that menu and those settings are set as I prefer. This does not update any of the tokens that came with the module though. There IS an option in game that says "apply default settings", but the token settings do not seem to be an option in that menu, only the character sheet settings. See my screenshot below. If you can't get it to show up (double checking the settings and reloading the game to be sure the apply defaults doesn't show the right menu), then you should probably submit a ticket on the Help Center for this.  I don't own any modules, but just confirmed I can enable/disable nameplates just fine through apply defaults on tokens I have out in a test game.  Submitting a ticket on it should get it to the right dev that works with the modules.