Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

UDL: Reveal explorable darkness leaves behind artifacts and breaks token vision


Edited 1615139261
Detailed description of the problem: I'm having some issues with the UDL feature and getting some unexpected behaviour. I've setup a test which i'm able to consistently repeat in multiple browsers with screenshots below. The left screenshot is of the GM view, the right is the token view (Ctrl + L). I'm trying to setup the map in a way where the players can see the entire map, but greyed out and also be able to clearly see what their token can see. (as seen in step 3). I've been playing around with it for a while and can't figure out how to consistantly achive this. The artifact box that is added after revealing a large area (step 2) is also very odd and doesn't seem to be the intended behaviour of this feature. There doesn't appear to be anything important in the Chrome's console log except for 1 item that occurs during step 4 when the token vision breaks. All other entires happen while the page is loading, nothing while i'm revealing areas or interacting with the token. "WebGL: INVALID_OPERATION: bindBuffer: attempt to use a deleted object app.js?1614965534:591" Description of setup: Browser: tested on the latest versions of Chrome, Chrome Incognito (no addons) and Firfox (no addons) OS: Windows 10 API: I had scripts running on the game when I took the screenshots but have since tested this on a clean game with no scripts running and got the same result. To reproduce the problem: 1. I have reset the explorable area and droped the token onto the page 2. I used the 'Reveal explorable area' tool to reveal the entire map. It reaveals the map but it then immiadtely adds a unexploded artifact box in the middle of the selected area. 3. Using the 'Reveal explorable area' tool again to reveal the artifact box will get rid of it, but I need to do this twice as it gets re-inserted after the first time. The end result is how i'm trying to get the map to look 4. If I change the page and come back to the test page, it re-inserts the artifact box but this time also breaks the tokens vision 5. To fix the tokens vision I have to reload the browser page (F5) which the map back to how it looks in step 2 6. This is the token and page settings. The 'Daylight mode', 'Update when Token Drop' and 'Night Vision' setting don't seem to make a differnece whether they are on/off with this bug.
Forum Champion
Marketplace Creator
API Scripter
I've noticed that too. It appears to be a GM-only artifact though, related to Ctrl-L. The players don't see that box--you can test with a  Dummy Account . Also, you should report this on  Updated Dynamic Lighting - Feedback Thread , where it will be seen by the dev team.
Thanks Keith, thats good to know. I'll have a play around with a dummy account and report this on the other thread as well.
Just to confirm, this is not a GM-only issue. Tested with dummy account and the artifact left after the reveal affects players as well
I'm having the same issue. This appears to have popped up in the last couple of weeks, as it was working 3 weeks ago, but was broken last Thursday when I tried to run a game using it.