Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
D&D 2024 has arrived! Pre-order the new core rulebooks now and get an exclusive pre-order bonus for free!
Create a free account

APi down again?

1405213692
DXWarlock
Sheet Author
API Scripter
Is the API having issues? Last few saturdays around this time the API starts getting unresponsive for us, it starts with the 'loop or long running process" errors for no reason (api wasnt even being used, we was talking on TS) and it wont respond to any commands or triggers. even my 'On ready" on saving scripts doesn't send a chat message like it should.
1405213822
The Aaron
Roll20 Production Team
API Scripter
I'm just getting: Infinite loop or long running process detected. constantly, regardless of what I do. Usually I can refresh the page and save to get things going, but that isn't helping.
1405213857
The Aaron
Roll20 Production Team
API Scripter
Also, the button goes from saving... to saved! suspiciously fast.
1405213883

Edited 1405213919
Seems like it's down, yes. I'm having issues too, I was wondering why all my scripts started to stop working for no reason.
1405213903
DXWarlock
Sheet Author
API Scripter
I noticed that too, no messages of: Restarting sandbox due to script changes... Spinning up new sandbox...
Mine says, "API sandbox shutdown due to campaign inactivity." We play every Saturday, first time seeing this.
1405220686
The Aaron
Roll20 Production Team
API Scripter
seems to be up again now.
Hmmm...as Aaron said it seems to have fixed itself but obviously going down at 8 PM on Saturday isn't very ideal...I hadn't noticed that this was a recurring thing at this time but you guys probably use it a lot more than I do. I'll take a look at our server logs and see what can be done. Might be time for another API server upgrade.
1405259983

Edited 1405262570
DXWarlock
Sheet Author
API Scripter
Yea, its working fine now. It seemed to kick back in for me around the same time Aaron posted. And thats the pattern I noticed, all week it works fine for my testing and setup..but last 2-3 weeks around 8pmEST on satruday is really really slow to respond, and usually finally results in the infinite loop or long running error even while idle not using it then it goes down for a bit.