Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Confused by result (or lack of)

Is there any reason why a macro calling a rollable table that works in my 5th ed D&D game wouldn't work in my Forbidden lands game? The contents of the tables are different, but the structure of the lists and the macro is essentially identical, and I can't figure out why one works and the other gives no results (no errors etc.) Are macros not 'universal'? Can anyone help please?
Sheet Author
Are you still trying to use a 5E roll template in the Forbidden Lands game?&nbsp; The only roll template that is universal is the default template, with anything else being part of character sheet code.&nbsp; You would need to be sure you are calling your rollable tables either with a template that is part of the Forbidden Lands character sheet or the default template to get things to work.&nbsp; <a href="" rel="nofollow"></a> That is my guess as to what is happening, but it is hard to tell without more information (like the exact macro you are trying to execute).
Thanks for the reply, Kraynic. I sort of stumble my way through macros, and although there has been plenty of help and examples for 5th ed D&amp;D, I can't find anything similar for FR (and this is a very new game for me). I have seen exactly the sort of macro that I am after in another post, but I will try your suggestion before heading off down that path :) Again, Thanks.
This is what I have 'cobbled' together so far /w gm &amp;{template:forbiddenlands} {{name= Random tables }} {{name=}} {{description=?{Choose |Hunting,[[1t[Hunting]]]|Hunting mishaps,[[1t[Hunting-mishaps]]]|Fishing mishaps,[[1t[Fishing-mishaps]]]|Making camp mishaps,[[1t[Making-camp-mishaps]]] } }} Which results in this which is not quite what I wanted :(
Dave L. said: This is what I have 'cobbled' together so far /w gm &amp;{template:forbiddenlands} {{name= Random tables }} {{name=}} {{description=?{Choose |Hunting,[[1t[Hunting]]]|Hunting mishaps,[[1t[Hunting-mishaps]]]|Fishing mishaps,[[1t[Fishing-mishaps]]]|Making camp mishaps,[[1t[Making-camp-mishaps]]] } }} Which results in this which is not quite what I wanted :( My first guess is that the tables you are trying to roll are in your 5e session not your forbidden lands session, and cause you are a plus account maybe you did make the effort of remaking the tables in the new session but the naming scheme for said tables are off?&nbsp; A pro user can simply drag and drop their tables between sessions with the transmogrifier but your account flair shows you as plus so confirm that you did indeed move the tables over and named them right.&nbsp;&nbsp; My next guess is maybe that the template requires spaces after the commas and that final space to be removed at the end of the query before its last bracket but it still worked in my session with a 5e sheet so I dunno.&nbsp;&nbsp; My money is on you just not realizing that the tables are session specific and you never remade them in your new session.&nbsp;&nbsp;
Thanks, DM EDDIE, actually they are not direct transfers, they are different lists created from scratch, to do something different than the ones in my other game.

Edited 1627329701
Sheet Author
API Scripter
You're picture isnt showing up. In my experience, its more reliable to upload pictures to another image host (like imgur), and embed the link here. First thing to check: are there any linebreaks in your macro? Roll20 thinks there are when I copy your macro and paste it into a code block I get this: /w gm &amp;{template:forbiddenlands} {{name= Random tables }} {{name=}} {{description=?{Choose |Hunting,[[1t[Hunting]]]|Hunting mishaps,[[1t[Hunting-mishaps]]]|Fishing mishaps,[[1t[Fishing-mishaps]]]|Making camp mishaps,[[1t[Making-camp-mishaps]]] } }} If so, you want to get rid of them, so it looks like this /w gm &amp;{template:forbiddenlands} {{name= Random tables }} {{name=}} {{description=?{Choose | Hunting,[[1t[Hunting]]]| Hunting mishaps,[[1t[Hunting-mishaps]]]| Fishing mishaps,[[1t[Fishing-mishaps]]]| Making camp mishaps,[[1t[Making-camp-mishaps]]] } }} You can have linebreaks after the | in queries, and its handy for layout. The next thing to do is dump the macro, and just try the table rolls individually and see they are working, like /roll 1t[Hunting] and repeat for each table. If they are working properly, then its time to look at the macro. I would try running the macro without the table calls, just text in their place, like /w gm &amp;{template:forbiddenlands} {{name= Random tables }} {{name=}} {{description=?{Choose | Hunting| Hunting mishaps| Fishing mishaps| Making camp mishaps} }} Those attempts should help narrow down the problem.

Edited 1627365288
Sheet Author
Here's an example of crit result query that rolls off of rollable tables using the Forbidden Lands template. (so calling rollable tables within the template "shouldn't" be a problem...) /w gm &amp;{template:forbiddenlands} {{name= Crit Result }} {{subtitle=?{Choose Crit |Blunt,Blunt-[[1t[crit_blunt]]]|Horror,Horror-[[1t[crit_horror]]]|Slash,Slash-[[1t[crit_slash]]]|Stab,Stab-[[1t[crit_stab]]] } }}
Ok table exists, but does its name directly match the macro?&nbsp; Cause I get the same result as you when I try to run it with no table by that name fwiw.&nbsp; Even capital letters matter and if you have a strange keyboard maybe a strange character?
Thanks for the very useful help, Guys, I now have a working macro that produces the results of table rolls that re-occur frequently :)