Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
×
We're investigating unusual elevated traffic on voice and video servers that is affecting connectivity. We are working towards a solution as quickly as possible! Sorry for the trouble!
Create a free account

Arrow Keys not moving tokens, cycles through chat, library tabs instead

1646601053

Edited 1646601172
Rob
Pro
When I (As DM in my own game) select a token and use the arrow keys (except left), the token moves one grid unit, then subsequent presses of the arrow key cycle through the chat, library, journal, etc tabs. The Left arrow key seems to work, the token moves left.  Is anyone else seeing this? or is it just me? Windows 10, Chrome version 99.0.4844.51 (Official Build) (64-bit)  ,turned all extensions off.
1646601862

Edited 1646678541
Rob
Pro
I bang my head against this for an hour, and 2 minutes after I post here, I found the answer. Somehow in Chrome    settings > advanced settings > accessibility > Navigate Pages with a Text Cursor  was turned on. Apparently the F7 key is what toggles this mode on. 
1646604867

Edited 1646604880
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Thanks for publishing the solution, Rob! Hopefully that will save some future user from the frustration you went through.
Can confirm, this has just saved me a ton of frustration. Thanks Rob!
Thanks. Your tip solved a big problem here. I suffered all night this weekend with this "problem". 
I'm glad to have helped!
You just solved this issue for me Rob. Thank you!
Thank you, thank you, thank you!
Thank you
Thank you, solved my issue. I had no idea what was happening.
Excellent stuff posting the solution, thanks!
Thank you Rob!
thank you Rob, you have just saved me some stress
Rob I love you, you are my new favourite person.
OMG. Thank you for this. It's been driving me crazy for the past few sessions. 
Solved it for a member of my group too, thanks Rob!
Rob youre the best!
Is there a solution for this in Firefox? I'm having this exact issue and cannot figure out how to fix it.
In Firefox's Settings--> General, scroll down to 'Browsing', and see if "Always use the the cursor keys to navigate within pages" is checked, and try unchecking that. I don't use Firefox, so it's only a guess. Good luck!
Thanks man, for those who were suffering from this like me and use Google Chrome, in the settings it explains that this accessibility option is activated by pressing F7. So I just pressed F7 and everything went back to normal
You're a life saver Rob, you should get the crown of the all mighty F7
OMG thank you!
1683699939

Edited 1683701242
I am having a similar issue, but sadly this setting does not fix it. When its disabled then arrow keys do nothing, but when its enabled the arrow keys just change between the chat, art library, journal etc etc at the top no matter what I do. I have the token selected and even then it just keeps switching between the menus at the top, any help with this would be greatly appreciated. Edit: This seems to only be an issue on chrome, tried it on a different browser and the arrow keys work just fine.
1683732797
Gauss
Forum Champion
Hi Ignorance,  I was not able to replicate this, could you supply the version of Chrome you are using?  Also, have you tried an Incognito tab in Chrome? If not please give that a try and see if it works.  Finally, you said "this setting does not fix it", which "setting" are you referencing? F7?
Thank you for the reply! But luckily I was able to figure out what was going on, turns out one of my extensions was the issue, but that got resolved after I updated it. The setting I was referring to was "Navigate pages with a text cursor" referring to the one mentioned by OP. Sorry to have wasted your time and thank you once more for still replying to me.
I also have this issue, with Firefox.   I can't use the cursor keys to move my tokens.   "Always use the cursor keys to navigate within pages" is unchecked.   Additionally, I used to be able to measure as I moved a token by tapping "q" but now that has changed. Sometimes it changes the mode from "select/move" to measure. 
1684116147

Edited 1684120424
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
The Q key issue has been reported elsewhere and will hopefully be fixed soon. Can you post the version of FF and the OS you use? I'll try to replicate the arrow keys issue.
1684131057

Edited 1684131316
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
PunyPaladin said: I also have this issue, with Firefox.   I can't use the cursor keys to move my tokens.   "Always use the cursor keys to navigate within pages" is unchecked.   I can duplicate this behavior on both Chrome and Firefox under specific circumstances: "Always use the cursor keys to navigate within pages" is unchecked.   If I click on the token and use the arrow keys, the token moves as expected. If I click on a tab header it will cycle through the tabs. If the token is still selected, it will also move the token. I have not noticed this behavior previously. I urge you to file a  Help Center Request . I will also report. In the meantime, make sure you last clicked upon a token to avoid changing tabs.