Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Gateway error accessing fate worlds celebration bundle.

Hello im having issues accessing the fate worlds celebration link:&nbsp; <a href="" rel="nofollow"></a> I have tried from different angles and web browsers and I get the same error.&nbsp; It says error reference #504 Host error. I want to buy the bundle.&nbsp; I have no issue accessing the other bundles or purchasing them, so it is baffling why I can't go into this one.&nbsp; Please help.

Edited 1652335373
Strange... I can access it and could potentially buy it (if I wanted to)... just tested it with the link provided...
I tried today at a friends house computer and get the same error. &nbsp;As i said in the og post, is really weird because I can access and buy the other bundles just not that one which is a bummer.
So, I still can't access it but I think I made the problem worst. I was able to add the bundle to my wish list from the page is listed. Now I cant open my wish list either... Whatever it is directly tied to that bundle. I also tried thru a VPN trying different countries and stuff just in case, but I was not able to access it either.
This is what I get to see after a comparably long loading time...
Yeah, I don't get there as soon as I hit the link it tries to load for a long time then it goes to the host error screen.&nbsp; Once, I was able to add it to the wish list on one of the bundle pages but there was no buy button.&nbsp; Once I added it to my wishlist that wishlist became inaccessible.&nbsp; This is what I see.&nbsp;
Forum Champion
Marketplace Creator
API Scripter
Hmm. Have you tried a private browsing window?
Just tried and I get the same error.&nbsp;