Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Change Critical Range on d10 Not Working

In the macro below, the critical failure on 1 and critical success on 10 are being properly recognized, but not the critical success on 9. ?{Attack |    Unmodified,/em **rolls a [[d10+?{Mod|6}cs>9cf1]] on an unmodified check!** |    Advantage,/em **rolls a [[2d10kh1+?{Mod|6}cs>9cf1]] on a check with Advantage! ** |    Disadvantage,/em **rolls a [[2d10kl1+?{Mod|6}cs>9cf1]] on a check with Disadvantage!** }

Edited 1700257617
Here is an example; note the check defaults to +6...
I also just tried a much simplified version with the same result: /em **rolls a [[d10+3cf1cs>9]] on a damage check!**
Try /em **rolls a [[d10cf1cs>9+3]] on a damage check!**
Well dang! That worked... Appreciate the help. For the record, it worked fine in the spot it was in for 1 and 10...

Edited 1700261004
Sheet Author
API Scripter
I am not commenting on the problem here, but the original macro construction. Generally speaking you want to rewrite a macro to reduce html substitutions. You have a query inside a query, but it looks like the inner query is the same in each of the 3 branches so you can move that outside of the outer query something like this: /em **rolls ?{Attack |    Unmodified,an unmodified check!**: [[d10cs>9cf1|    Advantage,a check with Advantage!**: [[2d10cs>9cf1kh1|    Disadvantage,a check with Disadvantage!**: [[2d10cs>9cf1kl1} + ?{Mod|0}]]
Just saw this... Thanks for the help