Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Trouble with recursive magic tables


Edited 1707505255
Hi all I found Matthew's gorgeous magic tables: <a href="" rel="nofollow"></a> I have downloaded his Excel, done the find and replace and then copy and pasted his various 5th columns in to chat.&nbsp; Everything seems fine, I now have a huge number of rollable tables and have opened every one, they all look good.&nbsp; When I try and run !rt[delimiter:br|maxdepth:25] /w gm &amp;{template:default} {{Magic-Item-Table-?{Table|A|B|C|D|E|F|G|H|I}= [[ ?{How Many?|1}t[Magic-Item-Table-?{Table}] ]]}} I get (From RecursiveTables): An Error occured with this message: /w gm &amp;{template:default} {{Magic-Item-Table-A= [[ 1t[Consumables-A] ]]}} Error: Expected "[" or [ |\t] but "1" found Whilst Matthew doesn't get that, it all works fine for him, I went in to every table and changed [[ 1t[tablename] ]] to [[1t[tablename]]] and now it wants to work.&nbsp; The problem is that despite changing maxdepth to 125 it seems to stop opening tables at a certain point and I am completely stumped.&nbsp; Screen shot below, anyone got any idea why? the rod, shield and ammo show this when hovered over I have also deleted and reinstalled recursivetable API v0.2.5
I thought I'd take Matthew's tables out of the mix as this looks more to be about how recursive tables is working for me.&nbsp; I created three simple tables as shown and when I run this (which I copied from a post by The Aaron and altered the table name) I get that output, so Table A is fine, the foxes entry comes from Table B but it is not rolling the number and Table B is leading to Table C but not accessing it? I have tried both Firefox and Chrome, Chrome has no extensions loaded, Firefox only has Stylus, but I have also tried with that turned off, all to no avail. I also turned off my antivirus just for giggles, made no difference (desperation stuff now!!)

Edited 1707568133
Captain's log supplemental... copied tables to a game that had only API heartbeat and SpawnDefaultToken APIs and we have a winner it would appear to be a conflict with another API, so will run through them until I find the culprit It makes absolutely no sense to me, but when Dynamic Lighting Tool is enabled on this game I get the trouble in the posts above.&nbsp; Interestingly if I add DLT to this new game I get better results but it still seems to jumble things up (lines appear mixed, so 3 foxes haunted encounter for example).&nbsp; I don't need to run DLT all the time so it is easy to disable it until needed. Now for coffee