Roll20 uses cookies to improve your experience on our site. Cookies enable you to enjoy certain features, social sharing functionality, and tailor message and display ads to your interests on our site and others. They also help us understand how our site is being used. By continuing to use our site, you consent to our use of cookies. Update your cookie preferences .
Create a free account

Upload to My Library Bug

Problem: I cannot upload new images into My Library. The primary file that I was attempting to upload is a 104 KB .jpg file on my Dev server game. I have since tried to upload different files on different campaigns including non-Dev ones and get the same result regardless. Clicking the Upload button brings up the Upload Files... window as normal and either selecting the file or dragging the file in from the folder results in the same thing. The green bar loads and moves back and forth for a second or two and then the message: "Upload Complete. Uploaded files are available under your Recent Uploads to add to the tabletop." Also for a brief second a yellow loading dialog "Loading Recent Uploads" appears under the Recent Uploads column on the right but when it goes away there is no change. I am using Chrome Version 52.0.2743.116 m but I have also tried it with Firefox and recieved the same issue. This is a pretty old campaign that I have been adding things to with no issues until the new layout of My Library was added. One interesting thing is that I am still able to add pictures to characters/handouts and then drag them out to make tokens so that's a work around. But I am not able to add art for a background which is what I need to be doing right now, and said tokens don't stick around in my library. System: Windows 10 Home v1151 Intel i7-2600 @3.4GHz, 8 GB RAM, 64 Bit

Edited 1471455723
KS Backer
If this helps: <a href="" rel="nofollow"></a> UPDATE - After looking at some of the other threads with the same issue I made a new campaign and low and behold I was able to add pictures on it. Now I can add pictures to all of my regular campaigns but not while on my Dev Server campaign which I used to be able to do and is where I spend most of my time. Pictures added to the regular ones appear there though, so guess it's a work around for now...
Phil B.
Forum Champion
Sheet Author
Yeah, there appears to be an issue with the Dev file upload code. But, luckily all of your uploaded images are shared between production and dev, so if you need an image uploaded you can upload it to a regular game and then search for it in the dev game. I have made note of this to fix eventually, but in the mean time this will be your best option.