Urgent - my image issues still not resolved, can't even prep my games

1484160610
After spending hours deleting more than half of my images because R20 has rendered them unusable, including messing up their names, an issue still not resolved, I fear it may happen again, which makes the site useless to storing images for quick finding.  But it got worse, I am now at the point - again - where the library will not load completely. At first, I thought it is because, for some reason, deleting an image from the library will not delete it from folders - which makes no sense but ok. As I could not delete the now broken images in the folders - again - I deleted the folders. One didn't allow itself to be deleted even, but to my knowledge no broken images in there anyway. Images in my library now load to different points anytime I try, but it never ever loads to the parts I need to prep my Sunday game. I can't even rely on something leading now still be accessible at the next reload. Sure, I can upload (and re-prep before doing so) all the images again, but my time and patience is running very short. But double images mean double space, and I would later probably not be able to delete (or reuse) those either. Please help me out here, my last post about the misnamed tokens was not even answered. The pointlessness of the library, if it persists, will mean I won't prolong my subscription if it is not fixed soon. As it is, I won't recommend others to spend money anymore. And no, it is not my computer, as it is the same on every computer I tried it on, with 2 different browsers and with no add ons etc.
1484268562
bump Already had to cancel a game for tomorrow.
1484350828
Kristin C.
Roll20 Dev Team
Marketplace Creator
Grimtina, how are you deleting your images? Are you doing it in Recent Uploads? Are you deleting it from another folder? Are you deleting them outside the VTT in the older build on the website?
1484486948

Edited 1484616099
Right now I am deleting them from the old marketplace link, as inside the games I can't access them anymore. Usually, I delete them right from Recent Uploads.
1484616366
Now I can't even get to the images I could still access last time anymore. Probably because I re-uploaded stuff. It is now either stuck at the Star Trek shuttle or a fire sprite.
1485987154
Issue persisting, I have to upload, delete, reupload all the time to make sure I can still at least access current images.