Several Problems With Roll20

1502555149

Edited 1502555491
cdrch
Plus
I am unable to do much of anything in Roll20 currently. The maps load extremely slowly, and tokens move inconsistently with the mouse, if at all. There is a delay in creating new character sheets, if they are created at all, and then show an error and fail to allow me to edit them. I also frequently fail to connect to the server, but the issues persist even when the warning disappears. I am essentially unable to use Roll20 with all these errors together. All steps were followed from the Solving Technical Issues wiki page, including disabling all addons, clearing the cache, and testing in both Chrome and Firefox. Detailed Description of the Problem In General: I receive the following error periodically, but the other issues occur regardless of the status of this error. However, sometimes Roll20 does not accept input at all while this error message is up. "Your connection to the server has been interrupted! Anything you do right now we'll attempt to send when you go back online, but to be on the safe side you may want to stop doing anything important. You may want to check our status site for more info." Map Issues: Maps load very slowly - 30 to 120 seconds or more to load the same map which previous has loaded in a few seconds. No fog of war or dynamic lighting is enabled, just a single large PNG image that covers the map (still far smaller than other maps that have loaded more quickly in the past). Tokens move erratically compared to mouse movement or slowly, or not at all. Character Sheets: I created new sheets several times, attempting to get one to work. First, they took a long time to appear in the Journal. Then, once there, if I open them, they are a blank white page. Clicking on edit gives me the error "ERROR: Unable to find character to edit." Steps to Reproduce the Problem Character Sheet Issue: 1. Log into Roll20. 2. Click "Join Game" to enter the campaign. 3. Wait for it to load. 4. Click on the Journal tab. 5. Click on the button to add. 6. Select "New Character". 7. Wait for it to appear at the bottom of the list. 8. Click on it to open it. Observe that it is blank aside from the row of buttons that includes "Edit". 9. Click on "Edit". Observe the pop-up error (image below). The other issues simply appear constantly or frequently with no apparent pattern based on time or my behavior after the game loads. Description of Your Setup (Browser + Version, Operating System, etc.) OS: Windows 10 Screen Resolution: 1920x1080 (Browser: 1920x950) Browser: Chrome 60.0.3112.90 (also tested with Firefox 54.0; JavaScript enabled on both) Antivirus: Avast Free Antivirus Console Log: https://pastebin.com/KuPPQP6s
1502558316
Drespar
Roll20 Development Team
Hi cdrch, What is the name of the game you are having issues in? Would you mind if I were to hop in and have a look?
1502565868
cdrch
Plus
ORSA RPG Group is the name of the game, and sure!
1502597198
Drespar
Roll20 Development Team
So after having a look in your game it looks as if it is pretty sizable. Did you make any recent large additions to the game? This could be in the form of a long piece of text in a handout, or a lot of tokens. I noticed some bogging down for a bit then everything seemed to be running fine for me. I noticed that you had a copy of the game, do you have the same issue in there? I might suggest making another and seeing if you are able to delete some items you do not need right away and see if that steps up the speed of your game.
1502650907
cdrch
Plus
I did not make any recent large additions - a couple of months ago was the largest bulk addition, and Roll20 continued to work fine up until a month ago or so, when I started to get significantly more Unable To Connect To Server messages. However, until yesterday, it had never failed to work quite like this. I tried today and after about 10-15 minutes of waiting, the Roll20 game seems to work, but the Unable To Connect messages are more frequent than ever. The other issues seem to go away after this wait. (Yesterday, they did not even go away after waiting for much longer.) Given the frequency of the disconnects, it's still likely to be unusable for me in an actual game. My internet speed is not great, but no other program (including games that have very high network update rates) has this kind of issues, so I don't think I can blame my net speed for this. I made a copy of the game, and it took something like 30 or more minutes to copy - and the copied game was entirely blank. All maps, sheets, and more were completely gone from the copy, so I can't really test to see if a small reduction in filesize helps. I tried with the older backup I had made, and it had the same issues as the current version.