Advertisement Create a free account

[5E OGL] NPC damage not rolling (not an auto-roll toggle issue)

1562792222
Hi, So I dragged and dropped a Compendium monster, with the intent of editing the sheet. I created an attack, with a proper damage roll. I have Do Not Auto Roll Damage set, because I don't want players to see the damage before they know if it hits or not. I click on the attack, it rolls to hit, fine. I click on the attack line to show the damage, and it displays "Damage:               " as if there is no damage roll implemented. It doesn't work for any damage roll I put in, in [[]] or not. I've filled it all the fields. Here are the troubleshooting steps I've taken: 1. The normal attack (which came when I dragged and dropped the sheet) works fine. I click the attack, then I click for damage, it displays fine. 2. If I set Auto Roll Damage on, it works fine. 3. Weirdly, if I disable the "Attack" checkbox, it'll roll the damage fine (it doesn't do an attack roll because it's not an attack, but it'll display a box showing the damage it does, using the roll I input when the Attack checkbox WAS checked. Really strange behavior. 4 Fixes I've tried: Brackets [[]], changing the die roll, changing from a melee attack to ranged attack, changing the range, changing everything. Nothing works. The temporary solution is to auto roll damage, I guess, but I'd prefer not to.
1562837204
Andreas J.
Roll20 Production Team
Sheet Author
I didn't manage to replicate this behaviour. What compendium monster did this happen with, and does this persist between different monsters?
1562856367

Edited 1562856832
It was a bog standard 1/4 CR Wolf, and I haven't yet tried it with another creature, I will though. Edit: I did rename it though. Edit2: I just tried it with a kobold, all rolls worked fine. Still not working with the wolf/guard dog.
1562866281
keithcurtis
Forum Champion
You could already have a wolf instance in your game that has been compromised. Dragging in a new wolf from the Compendium only places an instance of the existing wolf, not a fresh Compendium one (To guard against overwrites of custom creatures). To test, delete any existing wolf characters from your game and try with a fresh drag. That will help narrow down where the problem is coming from.
1562886390
This is a session 0 wolf. There are no other previous wolves.