Advertisement Create a free account

Announcement: DupCharToken now works with script library one-click install (which it previously was not)

1574851131
Chris D.
Pro
Sheet Author
API Scripter
dupCharToken V1.01 was modified to run a bit quicker, and now works with one-click install, so those of you who tried to install the previous version but ended up copying the code from github and pasting it in, can now just add the script. 
1574855280

Edited 1574855300
GiGs
Pro
Sheet Author
That's great news. What was the issue causing install to fail before?
1575005893
Chris D.
Pro
Sheet Author
API Scripter
Unknown. It had persisted through 2 or maybe 3 different version commits, but the only thing specific that I was doing rather different was that I made sure that the code did not start or end with blank lines or spaces. I would not think that this ought to have mattered at all, and in fact thought that blank lines ought to have been a plus to avoid problems, but it was the one thing I was doing differently than any other example I could find. 
1575377654
Laurent
Pro
API Scripter
What was the symptom when trying to add the script?
1575382878
GiGs
Pro
Sheet Author
Laurent said: What was the symptom when trying to add the script? If you tried to install via the one-click, it silently failed. If you used Import (so it copied the script to your library, and let you edit it), or manually installed it by copying from github and pasting it, it installed and worked fine.