We use Cookies to help personalize and improve Roll20. For more information on our use of non-essential Cookies, visit our Privacy Policy here.
Accept
Advertisement Create a free account

Simple macro for legendary creature not working...help?

I'm relatively new to writing macros but thanks to some youtube videos and a lot of help in these forums I have pretty much been able to figure things out until today. I was working on making macros for my first creature with legendary actions. The nested legendary action macro works perfectly but when I set up the macro for just the normal multiattack it is just showing up as a blank entry in the chat. It is also not whispered like the rest of the macros. Here is the macro I'm using for the multiattack. %{selected|repeating_npcaction_$0_npc_action}  %{selected|repeating_npcaction_$1_npc_action}  %{selected|repeating_npcaction_$1_npc_action}  %{selected|repeating_npcaction_$1_npc_action}  This is the same macro I'm using on my standard monsters and it works perfectly. The only difference is that this creature has legendary actions. I used this macro for the legendary actions. @{selected|wtype}&{template:npcaction} {{rname=@{selected|character_name}}} {{name=Legendary Actions}} {{description=[@{selected|repeating_npcaction-l_$0_name}](~selected|repeating_npcaction-l_$0_npc_action)[@{selected|repeating_npcaction-l_$1_name}](~selected|repeating_npcaction-l_$1_npc_action)[@{selected|repeating_npcaction-l_$2_name}](~selected|repeating_npcaction-l_$2_npc_action)[@{selected|repeating_npcaction-l_$3_name}](~selected|repeating_npcaction-l_$3_npc_action)}} I'm relatively certain I've missed something simple here and I would appreciate any guidance someone could offer. Thanks in advance.
1593453686

Edited 1593453886
This is what I have for the legendary actions main info box in my monster manual I am putting together- @{selected|wtype}&{template:npcaction} {{name=@{selected|npc_name}}} {{rname=Legendary Actions}} {{description=The @{selected|npc_name} can take @{selected|npc_legendary_actions} legendary actions, choosing from the options below. Only one legendary option can be used at a time and only at the end of another creature's turn. The @{selected|npc_name} regains spent legendary actions at the start of its turn.}} @{selected|charname_output} Then for each action I click the action in sheet go to the chat and press the up arrow. it will give you the specific macro for that action for example an Ancient Blue Dragon's detect action looks like this- %{selected|repeating_npcaction-l_$0_npc_action} the next action is $1 the next $2 and so on the only thing I see is you have the rname= and name= swapped and are missing some small items in the body of the macro. hope this works for you like it does for me.
1593455072

Edited 1593455479
Hi Mark, Thanks so much for your reply. The legendary action macro is actually working perfectly for me. For some reason it's the simple multiattack macro that isn't working properly. It's literally the same macro I use for all my other creatures with multiattack but on this specific creature it is just creating a blank output in the chat. I thought maybe it had something to do with the addition of legendary actions to the character sheet and maybe I need to change something in the basic repeating action macro. It doesn't seem like it should make a difference, but like I said I'm fairly new to this and I'm probably overlooking something (or making connections where there are none). I could also screenshot the character sheet if that would be helpful.  Thanks again for taking the time to respond. I do like the addition of the legendary action rules description into the macro. I added that in because although I was thinking I would remember it, I'm sure I will forget in the middle of a combat.
1593459940
I am pretty new myself but this is what works for me in the multi-attack and it also rolls the attacks and damage. Action: %{selected|repeating_npcaction_$0_npc_action} %{selected|repeating_npcaction_$1_npc_action} %{selected|repeating_npcaction_$2_npc_action} %{selected|repeating_npcaction_$2_npc_action}
Alright, thanks man. I'm starting to think there's some kind of glitch. This guy only has one actual attack action other than the multiattack description so that's why there's three repeating %{selected|repeating_npcaction_$1_npc_action}. 
1593486966

Edited 1593487017
Oosh
Plus
Have you tried it on more than one monster? It works fine for me. Just pasting this into chat: %{selected|repeating_npcaction_$0_npc_action} %{selected|repeating_npcaction_$1_npc_action} %{selected|repeating_npcaction_$1_npc_action} %{selected|repeating_npcaction_$1_npc_action} On a creature with legendary actions.
I did just try it on a dragon and everything works fine. I guess the legendary thing was a red herring. I can't figure out why it's not working. So if it's not a macro issue, could it be a character sheet issue? Here are a couple of screenshots if those help. <a href="https://imgur.com/a/79Qmn6U" rel="nofollow">https://imgur.com/a/79Qmn6U</a> &nbsp;
1593603038
Oosh
Plus
Maybe try running this just to check the skills are numbered properly: @{selected|repeating_npcaction_$0_name} @{selected|repeating_npcaction_$1_name} @{selected|repeating_npcaction_$2_name} @{selected|repeating_npcaction_$3_name} Is the "Multiattack" and "Bone Staff" you've rolled in the chat log (in the screenshots) from clicking on the sheet or from using the %{...} ability commands in chat? Only other thing I can think of is putting junk in between the ability calls: 0 %{selected|repeating_npcaction_$0_npc_action} 1 %{selected|repeating_npcaction_$1_npc_action} 2 %{selected|repeating_npcaction_$1_npc_action} 3 %{selected|repeating_npcaction_$1_npc_action} 4 just to see if it's outputting a blank line for each attempted ability call or what.
You're a genius. I tried adding a bunch of extra actions. %{selected|repeating_npcaction_$4_npc_action}&nbsp; %{selected|repeating_npcaction_$5_npc_action}&nbsp; %{selected|repeating_npcaction_$5_npc_action}&nbsp; %{selected|repeating_npcaction_$5_npc_action}&nbsp; Worked exactly as intended. Not sure what caused the character sheet to glitch in this way but the macro works now. Thank you so much!!!!
1593650762
Oosh
Plus
There's a few NPC sheets around with phantom fields from edits and whatnot, it seems like the repeating items aren't always properly removed.