We use Cookies to help personalize and improve Roll20. For more information on our use of non-essential Cookies, visit our Privacy Policy here.
Accept
Advertisement Create a free account

Webcam refuses to work with Roll20

1600202402

Edited 1600202502
I recently purchased a new webcam to use with Roll20 and other various group call programs. So far this webcam has succesfully worked on both discord and zoom. However, it when used on Roll20, it shows that it is connected, but no video shows up and my audio input is lost, removing even the buttons to mute myself. The only way to get my mic working again is to unplug the webcam. Does anyone have any ideas what might be causing this? I've gone through the webcam troubleshooting guide, but nothing seemed to help. Edit: The webcam model I am using is the aukey fhd, in case that helps.
1600205831
📜🗡Andreas J.🏹📜
Forum Champion
Sheet Author
What OS/Browser are you using? Also check this page <a href="https://roll20.zendesk.com/hc/en-us/articles/360039223594-Video-and-Voice-Chat-Troubleshooting" rel="nofollow">https://roll20.zendesk.com/hc/en-us/articles/360039223594-Video-and-Voice-Chat-Troubleshooting</a>
1600206175
I am running google chrome on windows 10, which are both up to date. my webcam works in the webRTC demo test.
1600207748
keithcurtis
Forum Champion
Marketplace Creator
API Scripter
Does it work through the web apps for those services (Discord and Zoom)? Does it fail to work on Roll20 in both Chrome and Firefox?
1600207827
Yes, it works on both discord and zoom. I haven't tried running it with roll20 on firefox, let me do that real quick.
1600208098
Okay, trying firefox produced some interesting results. My microphone appeared to work, and I was able to access my mute and stop video buttons (I was previously unable to access them on chrome) but it still didn't show any video.
1600235766
Brian C.
Pro
Marketplace Creator
Compendium Curator
You might want to check&nbsp; <a href="https://test.webrtc.org/" rel="nofollow">https://test.webrtc.org/</a> &nbsp;and see if it comes up with any glaring errors. Some missing things, like IPv6 are fine, but it sometimes picks up something that has a more obvious solution.
1600305252
using the test webrtc site, my setup cleared all hurdles except for Ipv6 and Reflex connectivity. The errors/warnings for Reflex connectivity were: [ INFO ] &nbsp; Gathered candidate of Type: srflx Protocol: udp Address: 73.240.84.73 [ WARN ] &nbsp; Could not connect using reflexive candidates, likely due to the network environment/configuration.